Jetson AGX Orin New Monitor

Hello,

I want to use my Jetson AGX Orin Developer Kit with a different monitor than the one I always use. But when I plug in the new monitor, the screen turns off after user login. When the device is running and I connect the old monitor, the desktop is visible.

In the display section of the settings, the old screen model always appears.

Is it possible to remove the old monitor and identify the new monitor?

What’s the spec/type/model of your old and new monitors?

The old monitor is Asus Tuf Gaming VG279QL1A 27", the new monitor is MSI Pro MP242 23.8". The new monitor does not have a Display port. But although the old monitor has Display port, I provide the connection via HDMI with Display Port to HDMI Converter. So I try to connect both monitors with this converter.

Hi,

Converter may not work well here. Especially for a converter that connects 2 monitors…

I can’t connect two monitors at the same time. I am using converter when connecting both monitors separately to Jetson board.

If you don’t connect two monitors, then what did you see in the desktop setting?

I am not quite sure if I understand your question here correctly.

I am not connecting these monitors at the same time. I am not using it as a dual monitor. I will be using the Jetson at the factory for a project. Therefore, I want to use the 24-inch monitor I bought for the project, not my own personal monitor, which is 27 inches. I don’t have any problems when I connect to Jetson with Display Port to HDMI Converter on 27 inch monitor. But when I connect it to Jetson with Display Port to HDMI Converter on the 24-inch monitor I bought for the project, I have the problem I wrote in the title. By the way, 24 inch monitor does not have Display port. I have to use converter. Why is there a problem with a 24 inch MSI monitor while a 27 inch Asus monitor is fine?

I may need to use different application-specific monitors in each project. Will I have this problem every time I change monitors?

Hi,

Now I understand your scenario, but what is the exact error here? Do you have any log to share? You can share /var/log/xorg.0.log when problematic monitor is in use.

The relevant log record is as follows. Here, Microstep MSI MP242 is the problematic monitor and AUS VG279QL1A is the working monitor.

[ 23.436] (–) Log file renamed from “/var/log/Xorg.pid-2013.log” to “/var/log/Xorg.0.log”
[ 23.437]
X.Org X Server 1.20.13
X Protocol Version 11, Revision 0
[ 23.437] Build Operating System: linux Ubuntu
[ 23.437] Current Operating System: Linux ubuntu 5.10.65-tegra #1 SMP PREEMPT Mon May 16 20:58:07 PDT 2022 aarch64
[ 23.437] Kernel command line: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 mminit_loglevel=4 console=ttyTCU0,115200 console=tty0 firmware_class.path=/etc/firmware fbcon=map:0 net.ifnames=0 nv-auto-config
[ 23.437] Build Date: 14 December 2021 02:14:13PM
[ 23.437] xorg-server 2:1.20.13-1ubuntu1~20.04.2 (For technical support please see Enterprise open source support | Ubuntu)
[ 23.437] Current version of pixman: 0.38.4
[ 23.437] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 23.437] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 23.437] (==) Log file: “/var/log/Xorg.0.log”, Time: Fri Jul 1 19:07:36 2022
[ 23.440] (==) Using config file: “/etc/X11/xorg.conf”
[ 23.440] (==) Using config directory: “/etc/X11/xorg.conf.d”
[ 23.440] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 23.443] (==) No Layout section. Using the first Screen section.
[ 23.443] (==) No screen section available. Using defaults.
[ 23.443] (
) |–>Screen “Default Screen Section” (0)
[ 23.443] () | |–>Monitor “”
[ 23.443] (==) No device specified for screen “Default Screen Section”.
Using the first device section listed.
[ 23.443] (
) | |–>Device “Tegra0”
[ 23.443] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 23.443] (==) Automatically adding devices
[ 23.443] (==) Automatically enabling devices
[ 23.443] (==) Automatically adding GPU devices
[ 23.443] (==) Automatically binding GPU devices
[ 23.443] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 23.446] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 23.446] Entry deleted from font path.
[ 23.446] (WW) The directory “/usr/share/fonts/X11/100dpi/” does not exist.
[ 23.446] Entry deleted from font path.
[ 23.446] (WW) The directory “/usr/share/fonts/X11/75dpi/” does not exist.
[ 23.446] Entry deleted from font path.
[ 23.446] (WW) The directory “/usr/share/fonts/X11/100dpi” does not exist.
[ 23.446] Entry deleted from font path.
[ 23.446] (WW) The directory “/usr/share/fonts/X11/75dpi” does not exist.
[ 23.446] Entry deleted from font path.
[ 23.446] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[ 23.446] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 23.446] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 23.446] (II) Loader magic: 0xaaaaab70c010
[ 23.446] (II) Module ABI versions:
[ 23.446] X.Org ANSI C Emulation: 0.4
[ 23.446] X.Org Video Driver: 24.1
[ 23.446] X.Org XInput driver : 24.1
[ 23.446] X.Org Server Extension : 10.0
[ 23.447] (++) using VT number 2

[ 23.448] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[ 23.449] (II) no primary bus or device found
[ 23.449] (WW) “dri” will not be loaded unless you’ve specified it to be loaded elsewhere.
[ 23.449] (II) “glx” will be loaded by default.
[ 23.449] (II) LoadModule: “extmod”
[ 23.449] (II) Module “extmod” already built-in
[ 23.449] (II) LoadModule: “glx”
[ 23.450] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 23.460] (II) Module glx: vendor=“X.Org Foundation”
[ 23.460] compiled for 1.20.13, module version = 1.0.0
[ 23.460] ABI class: X.Org Server Extension, version 10.0
[ 23.460] (II) LoadModule: “nvidia”
[ 23.461] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 23.479] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 23.479] compiled for 1.6.99.901, module version = 1.0.0
[ 23.480] Module class: X.Org Video Driver
[ 23.480] (II) NVIDIA dlloader X Driver 34.1.1 Release Build (bugfix_main) (buildbrain@mobile-u64-5414-d7000) Mon May 16 21:05:42 PDT 2022
[ 23.481] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 23.481] (WW) Falling back to old probe method for NVIDIA
[ 23.481] (II) Loading sub module “fb”
[ 23.481] (II) LoadModule: “fb”
[ 23.481] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 23.482] (II) Module fb: vendor=“X.Org Foundation”
[ 23.482] compiled for 1.20.13, module version = 1.0.0
[ 23.482] ABI class: X.Org ANSI C Emulation, version 0.4
[ 23.482] (II) Loading sub module “wfb”
[ 23.482] (II) LoadModule: “wfb”
[ 23.482] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 23.484] (II) Module wfb: vendor=“X.Org Foundation”
[ 23.484] compiled for 1.20.13, module version = 1.0.0
[ 23.484] ABI class: X.Org ANSI C Emulation, version 0.4
[ 23.484] (II) Loading sub module “ramdac”
[ 23.484] (II) LoadModule: “ramdac”
[ 23.484] (II) Module “ramdac” already built-in
[ 23.487] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 23.487] (II) NVIDIA(0): Creating default Display subsection in Screen section
“Default Screen Section” for depth/fbbpp 24/32
[ 23.488] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 23.488] (==) NVIDIA(0): RGB weight 888
[ 23.488] (==) NVIDIA(0): Default visual is TrueColor
[ 23.488] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 23.488] (DB) xf86MergeOutputClassOptions unsupported bus type 0
[ 23.488] () NVIDIA(0): Option “AllowEmptyInitialConfiguration” “true”
[ 23.488] (
) NVIDIA(0): Enabling 2D acceleration
[ 23.488] (II) Loading sub module “glxserver_nvidia”
[ 23.488] (II) LoadModule: “glxserver_nvidia”
[ 23.488] (II) Loading /usr/lib/xorg/modules/extensions/libglxserver_nvidia.so
[ 23.627] (II) Module glxserver_nvidia: vendor=“NVIDIA Corporation”
[ 23.627] compiled for 1.6.99.901, module version = 1.0.0
[ 23.627] Module class: X.Org Server Extension
[ 23.627] (II) NVIDIA GLX Module 34.1.1 Release Build (bugfix_main) (buildbrain@mobile-u64-5414-d7000) Mon May 16 21:02:35 PDT 2022
[ 23.628] (II) NVIDIA: The X server supports PRIME Render Offload.
[ 24.481] (–) NVIDIA(0): Valid display device(s) on GPU-0 at SoC
[ 24.482] (–) NVIDIA(0): DFP-0
[ 24.482] (–) NVIDIA(0): DFP-1
[ 24.482] (WW) NVIDIA: No DRM device: No direct render devices found.
[ 24.482] (II) NVIDIA(0): NVIDIA GPU Orin (nvgpu) (GA10B) at SoC (GPU-0)
[ 24.483] (–) NVIDIA(0): Memory: 31357604 kBytes
[ 24.483] (–) NVIDIA(0): VideoBIOS:
[ 24.483] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 24.483] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 24.483] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 24.483] (–) NVIDIA(GPU-0):
[ 24.578] (–) NVIDIA(GPU-0): Microstep MSI MP242 (DFP-1): connected
[ 24.578] (–) NVIDIA(GPU-0): Microstep MSI MP242 (DFP-1): Internal TMDS
[ 24.578] (–) NVIDIA(GPU-0): Microstep MSI MP242 (DFP-1): 165.0 MHz maximum pixel clock
[ 24.578] (–) NVIDIA(GPU-0):
[ 24.622] (==) NVIDIA(0):
[ 24.622] (==) NVIDIA(0): No modes were requested; the default mode “nvidia-auto-select”
[ 24.622] (==) NVIDIA(0): will be used as the requested mode.
[ 24.622] (==) NVIDIA(0):
[ 24.626] (II) NVIDIA(0): Validated MetaModes:
[ 24.626] (II) NVIDIA(0): “DFP-1:nvidia-auto-select”
[ 24.626] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[ 24.730] (–) NVIDIA(0): DPI set to (92, 91); computed from “UseEdidDpi” X config
[ 24.730] (–) NVIDIA(0): option
[ 24.730] (II) NVIDIA: Reserving 24576.00 MB of virtual memory for indirect memory
[ 24.730] (II) NVIDIA: access.
[ 24.730] (WW) NVIDIA(GPU-0): Failed to enter interactive mode.
[ 24.741] (EE) NVIDIA(0): Failed to allocate NVIDIA Error Handler
[ 24.741] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 24.741] (II) NVIDIA(0): may not be running or the “AcpidSocketPath” X
[ 24.741] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 24.741] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 24.741] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 24.741] (II) NVIDIA(0): details, please see the “ConnectToAcpid” and
[ 24.741] (II) NVIDIA(0): “AcpidSocketPath” X configuration options in Appendix B: X
[ 24.741] (II) NVIDIA(0): Config Options in the README.
[ 24.770] (II) NVIDIA(0): Setting mode “DFP-1:nvidia-auto-select”
[ 24.916] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 24.916] (==) NVIDIA(0): Backing store enabled
[ 24.916] (==) NVIDIA(0): Silken mouse enabled
[ 24.916] (==) NVIDIA(0): DPMS enabled
[ 24.916] (II) Loading sub module “dri2”
[ 24.916] (II) LoadModule: “dri2”
[ 24.916] (II) Module “dri2” already built-in
[ 24.916] (II) NVIDIA(0): [DRI2] Setup complete
[ 24.916] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 24.917] (II) Initializing extension Generic Event Extension
[ 24.917] (II) Initializing extension SHAPE
[ 24.917] (II) Initializing extension MIT-SHM
[ 24.917] (II) Initializing extension XInputExtension
[ 24.918] (II) Initializing extension XTEST
[ 24.918] (II) Initializing extension BIG-REQUESTS
[ 24.918] (II) Initializing extension SYNC
[ 24.918] (II) Initializing extension XKEYBOARD
[ 24.919] (II) Initializing extension XC-MISC
[ 24.919] (II) Initializing extension SECURITY
[ 24.919] (II) Initializing extension XFIXES
[ 24.919] (II) Initializing extension RENDER
[ 24.920] (II) Initializing extension RANDR
[ 24.920] (II) Initializing extension COMPOSITE
[ 24.920] (II) Initializing extension DAMAGE
[ 24.920] (II) Initializing extension MIT-SCREEN-SAVER
[ 24.920] (II) Initializing extension DOUBLE-BUFFER
[ 24.920] (II) Initializing extension RECORD
[ 24.920] (II) Initializing extension DPMS
[ 24.921] (II) Initializing extension Present
[ 24.921] (II) Initializing extension DRI3
[ 24.921] (II) Initializing extension X-Resource
[ 24.921] (II) Initializing extension XVideo
[ 24.921] (II) Initializing extension XVideo-MotionCompensation
[ 24.921] (II) Initializing extension SELinux
[ 24.921] (II) SELinux: Disabled on system
[ 24.921] (II) Initializing extension GLX
[ 24.921] (II) Initializing extension GLX
[ 24.921] (II) Indirect GLX disabled.
[ 24.921] (II) GLX: Another vendor is already registered for screen 0
[ 24.921] (II) Initializing extension XFree86-VidModeExtension
[ 24.921] (II) Initializing extension XFree86-DGA
[ 24.922] (II) Initializing extension XFree86-DRI
[ 24.922] (II) Initializing extension DRI2
[ 24.922] (II) Initializing extension NV-GLX
[ 24.922] (II) Initializing extension NV-CONTROL
[ 24.922] (II) Initializing extension XINERAMA
[ 25.013] (II) config/udev: Adding input device NVIDIA Jetson AGX Orin HDA HDMI/DP,pcm=3 (/dev/input/event5)
[ 25.013] (II) No input driver specified, ignoring this device.
[ 25.013] (II) This device may have been added with another device file.
[ 25.014] (II) config/udev: Adding input device NVIDIA Jetson AGX Orin HDA HDMI/DP,pcm=7 (/dev/input/event6)
[ 25.014] (II) No input driver specified, ignoring this device.
[ 25.014] (II) This device may have been added with another device file.
[ 25.014] (II) config/udev: Adding input device NVIDIA Jetson AGX Orin HDA HDMI/DP,pcm=8 (/dev/input/event7)
[ 25.015] (II) No input driver specified, ignoring this device.
[ 25.015] (II) This device may have been added with another device file.
[ 25.015] (II) config/udev: Adding input device NVIDIA Jetson AGX Orin HDA HDMI/DP,pcm=9 (/dev/input/event8)
[ 25.015] (II) No input driver specified, ignoring this device.
[ 25.015] (II) This device may have been added with another device file.
[ 25.016] (II) config/udev: Adding input device Logitech Wireless Mouse (/dev/input/event0)
[ 25.017] () Logitech Wireless Mouse: Applying InputClass “libinput pointer catchall”
[ 25.017] (II) LoadModule: “libinput”
[ 25.055] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[ 25.063] (II) Module libinput: vendor=“X.Org Foundation”
[ 25.063] compiled for 1.20.4, module version = 0.29.0
[ 25.063] Module class: X.Org XInput Driver
[ 25.063] ABI class: X.Org XInput driver, version 24.1
[ 25.063] (II) Using input driver ‘libinput’ for ‘Logitech Wireless Mouse’
[ 25.064] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 31 paused 0
[ 25.064] (
) Logitech Wireless Mouse: always reports core events
[ 25.064] () Option “Device” “/dev/input/event0”
[ 25.065] (
) Option “_source” “server/udev”
[ 25.081] (II) event0 - Logitech Wireless Mouse: is tagged by udev as: Mouse
[ 25.081] (II) event0 - Logitech Wireless Mouse: device is a pointer
[ 25.081] (II) event0 - Logitech Wireless Mouse: device removed
[ 25.081] () Option “config_info” “udev:/sys/devices/platform/3610000.xhci/usb1/1-4/1-4.2/1-4.2:1.2/0003:046D:C52B.0003/0003:046D:4055.0004/input/input20/event0”
[ 25.081] (II) XINPUT: Adding extended input device “Logitech Wireless Mouse” (type: MOUSE, id 6)
[ 25.082] (
) Option “AccelerationScheme” “none”
[ 25.082] () Logitech Wireless Mouse: (accel) selected scheme none/0
[ 25.082] (
) Logitech Wireless Mouse: (accel) acceleration factor: 2.000
[ 25.082] () Logitech Wireless Mouse: (accel) acceleration threshold: 4
[ 25.083] (II) event0 - Logitech Wireless Mouse: is tagged by udev as: Mouse
[ 25.083] (II) event0 - Logitech Wireless Mouse: device is a pointer
[ 25.084] (II) config/udev: Adding input device Logitech Wireless Mouse (/dev/input/mouse0)
[ 25.084] (II) No input driver specified, ignoring this device.
[ 25.084] (II) This device may have been added with another device file.
[ 25.085] (II) config/udev: Adding input device Logitech K540/K545 (/dev/input/event1)
[ 25.085] (
) Logitech K540/K545: Applying InputClass “libinput keyboard catchall”
[ 25.085] (II) Using input driver ‘libinput’ for ‘Logitech K540/K545’
[ 25.086] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 34 paused 0
[ 25.086] () Logitech K540/K545: always reports core events
[ 25.086] (
) Option “Device” “/dev/input/event1”
[ 25.086] () Option “_source” “server/udev”
[ 25.090] (II) event1 - Logitech K540/K545: is tagged by udev as: Keyboard
[ 25.090] (II) event1 - Logitech K540/K545: device is a keyboard
[ 25.090] (II) event1 - Logitech K540/K545: device removed
[ 25.090] (II) libinput: Logitech K540/K545: needs a virtual subdevice
[ 25.090] (
) Option “config_info” “udev:/sys/devices/platform/3610000.xhci/usb1/1-4/1-4.2/1-4.2:1.2/0003:046D:C52B.0003/0003:046D:4076.0005/input/input21/event1”
[ 25.091] (II) XINPUT: Adding extended input device “Logitech K540/K545” (type: MOUSE, id 7)
[ 25.091] () Option “AccelerationScheme” “none”
[ 25.091] (
) Logitech K540/K545: (accel) selected scheme none/0
[ 25.091] () Logitech K540/K545: (accel) acceleration factor: 2.000
[ 25.091] (
) Logitech K540/K545: (accel) acceleration threshold: 4
[ 25.094] (II) event1 - Logitech K540/K545: is tagged by udev as: Keyboard
[ 25.094] (II) event1 - Logitech K540/K545: device is a keyboard
[ 25.095] (II) config/udev: Adding input device gpio-keys (/dev/input/event4)
[ 25.095] () gpio-keys: Applying InputClass “libinput keyboard catchall”
[ 25.095] (II) Using input driver ‘libinput’ for ‘gpio-keys’
[ 25.096] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 35 paused 0
[ 25.096] (
) gpio-keys: always reports core events
[ 25.096] () Option “Device” “/dev/input/event4”
[ 25.096] (
) Option “_source” “server/udev”
[ 25.097] (II) event4 - gpio-keys: is tagged by udev as: Keyboard
[ 25.097] (II) event4 - gpio-keys: device is a keyboard
[ 25.098] (II) event4 - gpio-keys: device removed
[ 25.098] () Option “config_info” “udev:/sys/devices/platform/gpio-keys/input/input5/event4”
[ 25.098] (II) XINPUT: Adding extended input device “gpio-keys” (type: KEYBOARD, id 8)
[ 25.098] (
) Option “xkb_model” “pc105”
[ 25.098] () Option “xkb_layout” “tr,us”
[ 25.098] (
) Option “xkb_options” “grp_led:scroll”
[ 25.130] (II) event4 - gpio-keys: is tagged by udev as: Keyboard
[ 25.130] (II) event4 - gpio-keys: device is a keyboard
[ 25.140] () Logitech K540/K545: Applying InputClass “libinput keyboard catchall”
[ 25.140] (II) Using input driver ‘libinput’ for ‘Logitech K540/K545’
[ 25.140] (II) systemd-logind: returning pre-existing fd for /dev/input/event1 13:65
[ 25.141] (
) Logitech K540/K545: always reports core events
[ 25.141] () Option “Device” “/dev/input/event1”
[ 25.141] (
) Option “_source” “_driver/libinput”
[ 25.141] (II) libinput: Logitech K540/K545: is a virtual subdevice
[ 25.141] () Option “config_info” “udev:/sys/devices/platform/3610000.xhci/usb1/1-4/1-4.2/1-4.2:1.2/0003:046D:C52B.0003/0003:046D:4076.0005/input/input21/event1”
[ 25.141] (II) XINPUT: Adding extended input device “Logitech K540/K545” (type: KEYBOARD, id 9)
[ 25.141] (
) Option “xkb_model” “pc105”
[ 25.141] () Option “xkb_layout” “tr,us”
[ 25.141] (
) Option “xkb_options” “grp_led:scroll”
[ 26.060] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 26.061] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 26.061] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 26.061] (–) NVIDIA(GPU-0):
[ 26.074] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 26.074] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 26.074] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 26.074] (–) NVIDIA(GPU-0):
[ 28.029] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 28.029] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 28.029] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 28.029] (–) NVIDIA(GPU-0):
[ 28.044] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 28.044] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 28.044] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 28.044] (–) NVIDIA(GPU-0):
[ 28.047] (II) NVIDIA(0): Setting mode “NULL”
[ 28.136] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 28.136] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 28.136] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 28.136] (–) NVIDIA(GPU-0):
[ 28.152] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 28.152] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 28.152] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 28.152] (–) NVIDIA(GPU-0):
[ 55.965] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): connected
[ 55.966] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): Internal TMDS
[ 55.966] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): 165.0 MHz maximum pixel clock
[ 55.966] (–) NVIDIA(GPU-0):
[ 55.970] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 55.971] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 55.971] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 55.971] (–) NVIDIA(GPU-0):
[ 56.062] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): connected
[ 56.062] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): Internal TMDS
[ 56.062] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): 165.0 MHz maximum pixel clock
[ 56.062] (–) NVIDIA(GPU-0):
[ 56.095] (II) NVIDIA(0): Setting mode “DP-1: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}”
[ 56.409] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): connected
[ 56.409] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): Internal TMDS
[ 56.409] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): 165.0 MHz maximum pixel clock
[ 56.409] (–) NVIDIA(GPU-0):
[ 56.503] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): connected
[ 56.503] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): Internal TMDS
[ 56.503] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): 165.0 MHz maximum pixel clock
[ 56.503] (–) NVIDIA(GPU-0):
[ 56.522] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 56.522] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 56.522] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 56.522] (–) NVIDIA(GPU-0):
[ 56.613] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): connected
[ 56.613] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): Internal TMDS
[ 56.613] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): 165.0 MHz maximum pixel clock
[ 56.613] (–) NVIDIA(GPU-0):
[ 58.043] (–) NVIDIA(GPU-0): DFP-1: connected
[ 58.044] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 58.044] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 58.044] (–) NVIDIA(GPU-0):
[ 58.190] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): connected
[ 58.190] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): Internal TMDS
[ 58.190] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): 165.0 MHz maximum pixel clock
[ 58.190] (–) NVIDIA(GPU-0):
[ 64.256] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 64.256] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 64.257] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 64.257] (–) NVIDIA(GPU-0):
[ 64.347] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): connected
[ 64.347] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): Internal TMDS
[ 64.347] (–) NVIDIA(GPU-0): AUS VG279QL1A (DFP-1): 165.0 MHz maximum pixel clock

After sharing the log records, I experimented with 3 different monitors. I’m writing the monitors I tried these tests and their results below.

1.) Asus VA24EHE 23.8" 75Hz 5ms (HDMI+Analog) → Failed
2.) Dell S3221QS 31.5’’ 60Hz 4ms (HDMI+Display) → Failed (I connected this model directly via display port.)
3.) Asus VG248QG 24" 165 Hz 0.5ms (HDMI+Display) → Successful (I connected this monitor to Jetson with Display to HDMI converter.)

I noticed this detail here. Asus VG279QL1A monitor, which is my own monitor, is 165 Hz, and the Asus VG248QG monitor, which was successful in the tests, is 165 Hz.

Could it be because they are lower than 165 Hz that I am having problems with other monitors?