Jetson AGX Xavier can't entry the graphical

My device is Jetson AGX Xavier official carrier board

My device was working on interface of graphical before I having the problem like as below:

cp: not writing through dangling sylink'etc / resolv.conf
cgroup: cgroup2: unknown option "nsdelegate"
random: crng init done
random: 7 urandom warning (s) missed due to rate limiting
using random self ethernet address
using random host ethernet address
using random self ethernet address
using random host ethernet address

After the tty6 model is open, then I Enter the command clt+alt+F1~F6 is working.

I reference the links https://forums.developer.nvidia.com/t/why-the-hdmi-cant-display-gui-desktop-but-the-tty-console-is-ok-on-our-own-carrier-board/56066/4 to try to solving my issue

$ sudo -s
$ find /sys -name edid
$ cat `find /sys/ -name edid`

output:

No EDID
No EDID
 00 ff ff ff ff ff ff 00 10 ac 7a a0 53 33 58 30
 12 1a 01 03 80 34 20 78 ea ee 95 a3 54 4c 99 26
 0f 50 54 a1 08 00 81 40 81 80 a9 40 b3 00 d1 c0
 01 01 01 01 01 01 28 3c 80 a0 70 b0 23 40 30 20
 36 00 06 44 21 00 00 1a 00 00 00 ff 00 4e 35 37
 58 39 36 35 33 30 58 33 53 0a 00 00 00 fc 00 44
 45 4c 4c 20 55 32 34 31 32 4d 0a 20 00 00 00 fd
 00 32 3d 1e 53 11 00 0a 20 20 20 20 20 20 00 4a

Past the above data into http://www.edidreader.com/,
output:

I add `Option “ModeDebug”’ to the Section “Device” of Mine “/etc/X11/xorg.conf” file and execute the command and I see the output below

$ cat /var/log/Xorg.0.log

output:

[    10.668] (--) Log file renamed from "/var/log/Xorg.pid-6840.log" to "/var/log/Xorg.0.log"
[    10.670] 
X.Org X Server 1.19.6
Release Date: 2017-12-20
[    10.670] X Protocol Version 11, Revision 0
[    10.670] Build Operating System: Linux 4.15.0-140-generic aarch64 Ubuntu
[    10.670] Current Operating System: Linux agx 4.9.140-tegra #1 SMP PREEMPT Tue Oct 27 21:02:46 PDT 2020 aarch64
[    10.670] Kernel command line: console=ttyTCU0,115200 video=tegrafb no_console_suspend=1 earlycon=tegra_comb_uart,mmio32,0x0c168000 gpt tegra_fbmem=0x140000@0xa069d000 lut_mem=0x2008@0xa0697000 usbcore.old_scheme_first=1 tegraid=19.1.2.0.0 maxcpus=8 boot.slot_suffix= boot.ratchetvalues=0.4.2 vpr_resize sdhci_tegra.en_boot_part_access=1   usbcore.usbfs_memory_mb=1000  quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 rootfstype=ext4
[    10.671] Build Date: 08 April 2021  01:53:49PM
[    10.671] xorg-server 2:1.19.6-1ubuntu4.9 (For technical support please see http://www.ubuntu.com/support) 
[    10.671] Current version of pixman: 0.34.0
[    10.671]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    10.671] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    10.671] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun  8 16:29:06 2021
[    10.672] (==) Using config file: "/etc/X11/xorg.conf"
[    10.672] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    10.674] (==) No Layout section.  Using the first Screen section.
[    10.674] (==) No screen section available. Using defaults.
[    10.674] (**) |-->Screen "Default Screen Section" (0)
[    10.674] (**) |   |-->Monitor "<default monitor>"
[    10.675] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[    10.675] (**) |   |-->Device "Tegra0"
[    10.675] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    10.675] (==) Automatically adding devices
[    10.675] (==) Automatically enabling devices
[    10.675] (==) Automatically adding GPU devices
[    10.675] (==) Automatically binding GPU devices
[    10.675] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    10.675] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    10.675]    Entry deleted from font path.
[    10.675] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    10.675]    Entry deleted from font path.
[    10.675] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    10.675]    Entry deleted from font path.
[    10.675] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    10.675]    Entry deleted from font path.
[    10.675] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    10.675]    Entry deleted from font path.
[    10.675] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/Type1,
        built-ins
[    10.675] (==) ModulePath set to "/usr/lib/xorg/modules"
[    10.675] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    10.675] (II) Loader magic: 0x5589224010
[    10.676] (II) Module ABI versions:
[    10.676]    X.Org ANSI C Emulation: 0.4
[    10.676]    X.Org Video Driver: 23.0
[    10.676]    X.Org XInput driver : 24.1
[    10.676]    X.Org Server Extension : 10.0
[    10.677] (++) using VT number 1

[    10.683] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    10.685] (II) no primary bus or device found
[    10.685] (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
[    10.685] (II) "glx" will be loaded by default.
[    10.685] (II) LoadModule: "extmod"
[    10.685] (II) Module "extmod" already built-in
[    10.685] (II) LoadModule: "glx"
[    10.688] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    10.700] (II) Module glx: vendor="X.Org Foundation"
[    10.700]    compiled for 1.19.6, module version = 1.0.0
[    10.700]    ABI class: X.Org Server Extension, version 10.0
[    10.700] (II) LoadModule: "nvidia"
[    10.700] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    10.718] (II) Module nvidia: vendor="NVIDIA Corporation"
[    10.718]    compiled for 4.0.2, module version = 1.0.0
[    10.718]    Module class: X.Org Video Driver
[    10.725] (II) NVIDIA dlloader X Driver  32.4.4  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-4294)  Tue Oct 27 21:02:20 PDT 2020
[    10.725] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    10.725] (WW) Falling back to old probe method for NVIDIA
[    10.725] (II) Loading sub module "fb"
[    10.725] (II) LoadModule: "fb"
[    10.726] (II) Loading /usr/lib/xorg/modules/libfb.so
[    10.728] (II) Module fb: vendor="X.Org Foundation"
[    10.729]    compiled for 1.19.6, module version = 1.0.0
[    10.729]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.729] (II) Loading sub module "wfb"
[    10.729] (II) LoadModule: "wfb"
[    10.729] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    10.731] (II) Module wfb: vendor="X.Org Foundation"
[    10.731]    compiled for 1.19.6, module version = 1.0.0
[    10.731]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.731] (II) Loading sub module "ramdac"
[    10.731] (II) LoadModule: "ramdac"
[    10.731] (II) Module "ramdac" already built-in
[    10.732] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    10.733] (II) NVIDIA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    10.733] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    10.733] (==) NVIDIA(0): RGB weight 888
[    10.733] (==) NVIDIA(0): Default visual is TrueColor
[    10.733] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    10.733] (DB) xf86MergeOutputClassOptions unsupported bus type 0
[    10.733] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration" "true"
[    10.733] (**) NVIDIA(0): Enabling 2D acceleration
[    10.733] (II) Loading sub module "glxserver_nvidia"
[    10.733] (II) LoadModule: "glxserver_nvidia"
[    10.733] (II) Loading /usr/lib/xorg/modules/extensions/libglxserver_nvidia.so
[    10.834] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[    10.834]    compiled for 4.0.2, module version = 1.0.0
[    10.834]    Module class: X.Org Server Extension
[    10.834] (II) NVIDIA GLX Module  32.4.4  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-4294)  Tue Oct 27 21:00:13 PDT 2020
[    10.876] (--) NVIDIA(0): Valid display device(s) on GPU-0 at SoC
[    10.876] (--) NVIDIA(0):     DFP-0
[    10.876] (--) NVIDIA(0):     DFP-1
[    10.876] (--) NVIDIA(0):     DFP-2
[    10.876] (II) NVIDIA(0): NVIDIA GPU Xavier (nvgpu) (GV11B) at SoC (GPU-0)
[    10.876] (--) NVIDIA(0): Memory: 32691648 kBytes
[    10.876] (--) NVIDIA(0): VideoBIOS: 
[    10.876] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): connected
[    10.876] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): External TMDS
[    10.877] (==) NVIDIA(0): 
[    10.877] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    10.877] (==) NVIDIA(0):     will be used as the requested mode.
[    10.877] (==) NVIDIA(0): 
[    10.877] (II) NVIDIA(0): Validated MetaModes:
[    10.877] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[    10.877] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
[    10.880] (--) NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
[    10.880] (--) NVIDIA(0):     option
[    10.880] (--) Depth 24 pixmap format is 32 bpp
[    10.880] (II) NVIDIA: Reserving 24576.00 MB of virtual memory for indirect memory
[    10.880] (II) NVIDIA:     access.
[    10.891] (EE) NVIDIA(0): Failed to allocate NVIDIA Error Handler
[    10.891] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    10.891] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    10.891] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    10.891] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    10.891] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    10.891] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    10.891] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    10.891] (II) NVIDIA(0):     Config Options in the README.
[    10.956] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[    11.069] (==) NVIDIA(0): Disabling shared memory pixmaps
[    11.069] (==) NVIDIA(0): Backing store enabled
[    11.069] (==) NVIDIA(0): Silken mouse enabled
[    11.069] (==) NVIDIA(0): DPMS enabled
[    11.070] (II) Loading sub module "dri2"
[    11.070] (II) LoadModule: "dri2"
[    11.070] (II) Module "dri2" already built-in
[    11.070] (II) NVIDIA(0): [DRI2] Setup complete
[    11.070] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    11.073] (--) RandR disabled
[    11.085] (II) SELinux: Disabled on system
[    11.087] (II) Initializing extension GLX
[    11.087] (II) Indirect GLX disabled.
[    11.274] (II) config/udev: Adding input device tegra-hda-galen-t194 HDMI/DP,pcm=3 (/dev/input/event0)
[    11.274] (II) No input driver specified, ignoring this device.
[    11.274] (II) This device may have been added with another device file.
[    11.275] (II) config/udev: Adding input device tegra-hda-galen-t194 HDMI/DP,pcm=7 (/dev/input/event1)
[    11.275] (II) No input driver specified, ignoring this device.
[    11.275] (II) This device may have been added with another device file.
[    11.275] (II) config/udev: Adding input device tegra-hda-galen-t194 HDMI/DP,pcm=8 (/dev/input/event2)
[    11.275] (II) No input driver specified, ignoring this device.
[    11.275] (II) This device may have been added with another device file.
[    11.276] (II) config/udev: Adding input device tegra-hda-galen-t194 HDMI/DP,pcm=9 (/dev/input/event3)
[    11.276] (II) No input driver specified, ignoring this device.
[    11.276] (II) This device may have been added with another device file.
[    11.278] (II) config/udev: Adding input device gpio-keys (/dev/input/event5)
[    11.278] (**) gpio-keys: Applying InputClass "libinput keyboard catchall"
[    11.278] (II) LoadModule: "libinput"
[    11.279] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    11.288] (II) Module libinput: vendor="X.Org Foundation"
[    11.288]    compiled for 1.19.6, module version = 0.27.1
[    11.288]    Module class: X.Org XInput Driver
[    11.288]    ABI class: X.Org XInput driver, version 24.1
[    11.288] (II) Using input driver 'libinput' for 'gpio-keys'
[    11.290] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 35 paused 0
[    11.290] (**) gpio-keys: always reports core events
[    11.291] (**) Option "Device" "/dev/input/event5"
[    11.291] (**) Option "_source" "server/udev"
[    11.292] (II) event5  - gpio-keys: is tagged by udev as: Keyboard
[    11.292] (II) event5  - gpio-keys: device is a keyboard
[    11.292] (II) event5  - gpio-keys: device removed
[    11.292] (**) Option "config_info" "udev:/sys/devices/gpio-keys/input/input5/event5"
[    11.292] (II) XINPUT: Adding extended input device "gpio-keys" (type: KEYBOARD, id 6)
[    11.292] (**) Option "xkb_model" "pc105"
[    11.292] (**) Option "xkb_layout" "us"
[    11.293] (II) event5  - gpio-keys: is tagged by udev as: Keyboard
[    11.293] (II) event5  - gpio-keys: device is a keyboard
[    11.294] (II) config/udev: Adding input device tegra-snd-t19x-mobile-rt565x Headset Jack (/dev/input/event4)
[    11.295] (**) tegra-snd-t19x-mobile-rt565x Headset Jack: Applying InputClass "libinput keyboard catchall"
[    11.295] (II) Using input driver 'libinput' for 'tegra-snd-t19x-mobile-rt565x Headset Jack'
[    11.298] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 38 paused 0
[    11.298] (**) tegra-snd-t19x-mobile-rt565x Headset Jack: always reports core events
[    11.298] (**) Option "Device" "/dev/input/event4"
[    11.298] (**) Option "_source" "server/udev"
[    11.299] (II) event4  - tegra-snd-t19x-mobile-rt565x Headset Jack: is tagged by udev as: Keyboard Switch
[    11.299] (II) event4  - tegra-snd-t19x-mobile-rt565x Headset Jack: device is a keyboard
[    11.299] (II) event4  - tegra-snd-t19x-mobile-rt565x Headset Jack: device removed
[    11.299] (**) Option "config_info" "udev:/sys/devices/sound/sound/card1/input4/event4"
[    11.299] (II) XINPUT: Adding extended input device "tegra-snd-t19x-mobile-rt565x Headset Jack" (type: KEYBOARD, id 7)
[    11.299] (**) Option "xkb_model" "pc105"
[    11.299] (**) Option "xkb_layout" "us"
[    11.300] (II) event4  - tegra-snd-t19x-mobile-rt565x Headset Jack: is tagged by udev as: Keyboard Switch
[    11.300] (II) event4  - tegra-snd-t19x-mobile-rt565x Headset Jack: device is a keyboard
[    13.979] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): connected
[    13.979] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): External TMDS
[    14.415] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): connected
[    14.416] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): External TMDS
[    28.890] (II) config/udev: Adding input device Telink Wireless Receiver (/dev/input/mouse0)
[    28.890] (II) No input driver specified, ignoring this device.
[    28.890] (II) This device may have been added with another device file.
[    28.958] (II) config/udev: Adding input device Telink Wireless Receiver (/dev/input/event7)
[    28.958] (**) Telink Wireless Receiver: Applying InputClass "libinput keyboard catchall"
[    28.958] (II) Using input driver 'libinput' for 'Telink Wireless Receiver'
[    28.960] (II) systemd-logind: got fd for /dev/input/event7 13:71 fd 52 paused 0
[    28.960] (**) Telink Wireless Receiver: always reports core events
[    28.960] (**) Option "Device" "/dev/input/event7"
[    28.960] (**) Option "_source" "server/udev"
[    28.961] (II) event7  - Telink Wireless Receiver: is tagged by udev as: Keyboard
[    28.961] (II) event7  - Telink Wireless Receiver: device is a keyboard
[    28.961] (II) event7  - Telink Wireless Receiver: device removed
[    28.961] (**) Option "config_info" "udev:/sys/devices/3610000.xhci/usb1/1-4/1-4:1.1/0003:248A:8367.0002/input/input7/event7"
[    28.961] (II) XINPUT: Adding extended input device "Telink Wireless Receiver" (type: KEYBOARD, id 8)
[    28.961] (**) Option "xkb_model" "pc105"
[    28.962] (**) Option "xkb_layout" "us"
[    28.962] (WW) Option "xkb_variant" requires a string value
[    28.962] (WW) Option "xkb_options" requires a string value
[    28.965] (II) event7  - Telink Wireless Receiver: is tagged by udev as: Keyboard
[    28.965] (II) event7  - Telink Wireless Receiver: device is a keyboard
[    28.980] (II) config/udev: Adding input device Telink Wireless Receiver (/dev/input/event6)
[    28.980] (**) Telink Wireless Receiver: Applying InputClass "libinput pointer catchall"
[    28.980] (**) Telink Wireless Receiver: Applying InputClass "libinput keyboard catchall"
[    28.980] (II) Using input driver 'libinput' for 'Telink Wireless Receiver'
[    28.984] (II) systemd-logind: got fd for /dev/input/event6 13:70 fd 53 paused 0
[    28.984] (**) Telink Wireless Receiver: always reports core events
[    28.984] (**) Option "Device" "/dev/input/event6"
[    28.984] (**) Option "_source" "server/udev"
[    28.985] (II) event6  - Telink Wireless Receiver: is tagged by udev as: Keyboard Mouse
[    28.985] (II) event6  - Telink Wireless Receiver: device is a pointer
[    28.985] (II) event6  - Telink Wireless Receiver: device is a keyboard
[    28.985] (II) event6  - Telink Wireless Receiver: device removed
[    28.986] (II) libinput: Telink Wireless Receiver: needs a virtual subdevice
[    28.986] (**) Option "config_info" "udev:/sys/devices/3610000.xhci/usb1/1-4/1-4:1.0/0003:248A:8367.0001/input/input6/event6"
[    28.986] (II) XINPUT: Adding extended input device "Telink Wireless Receiver" (type: MOUSE, id 9)
[    28.987] (**) Option "AccelerationScheme" "none"
[    28.988] (**) Telink Wireless Receiver: (accel) selected scheme none/0
[    28.988] (**) Telink Wireless Receiver: (accel) acceleration factor: 2.000
[    28.988] (**) Telink Wireless Receiver: (accel) acceleration threshold: 4
[    28.989] (II) event6  - Telink Wireless Receiver: is tagged by udev as: Keyboard Mouse
[    28.989] (II) event6  - Telink Wireless Receiver: device is a pointer
[    28.989] (II) event6  - Telink Wireless Receiver: device is a keyboard
[    28.990] (**) Telink Wireless Receiver: Applying InputClass "libinput pointer catchall"
[    28.990] (**) Telink Wireless Receiver: Applying InputClass "libinput keyboard catchall"
[    28.990] (II) Using input driver 'libinput' for 'Telink Wireless Receiver'
[    28.990] (II) systemd-logind: returning pre-existing fd for /dev/input/event6 13:70
[    28.990] (**) Telink Wireless Receiver: always reports core events
[    28.990] (**) Option "Device" "/dev/input/event6"
[    28.990] (**) Option "_source" "_driver/libinput"
[    28.990] (II) libinput: Telink Wireless Receiver: is a virtual subdevice
[    28.990] (**) Option "config_info" "udev:/sys/devices/3610000.xhci/usb1/1-4/1-4:1.0/0003:248A:8367.0001/input/input6/event6"
[    28.990] (II) XINPUT: Adding extended input device "Telink Wireless Receiver" (type: KEYBOARD, id 10)
[    28.990] (**) Option "xkb_model" "pc105"
[    28.990] (**) Option "xkb_layout" "us"
[    28.990] (WW) Option "xkb_variant" requires a string value
[    28.990] (WW) Option "xkb_options" requires a string value
[155146.590] (**) Option "fd" "35"
[155146.590] (II) event5  - gpio-keys: device removed
[155146.591] (**) Option "fd" "38"
[155146.591] (II) event4  - tegra-snd-t19x-mobile-rt565x Headset Jack: device removed
[155146.591] (**) Option "fd" "52"
[155146.591] (II) event7  - Telink Wireless Receiver: device removed
[155146.591] (**) Option "fd" "53"
[155146.591] (**) Option "fd" "53"
[155146.591] (II) event6  - Telink Wireless Receiver: device removed
[155146.629] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[155146.636] (II) UnloadModule: "libinput"
[155146.636] (II) systemd-logind: not releasing fd for 13:70, still in use
[155146.636] (II) UnloadModule: "libinput"
[155146.636] (II) systemd-logind: releasing fd for 13:70
[155148.108] (II) UnloadModule: "libinput"
[155148.108] (II) systemd-logind: releasing fd for 13:71
[155148.109] (II) UnloadModule: "libinput"
[155148.109] (II) systemd-logind: releasing fd for 13:68
[155148.110] (II) UnloadModule: "libinput"
[155148.111] (II) systemd-logind: releasing fd for 13:69
[155148.232] (II) NVIDIA(GPU-0): Deleting GPU-0
[155148.234] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[155148.234] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[155148.234] (WW) xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[155148.316] (II) Server terminated successfully (0). Closing log file.

Hi, everyone
Any help and advices that is my appreciation!

This is not error log. It exists there even in normal boot case. You just didn’t notice them because there was the desktop showing up and covers them.

Your xorg.0.log has a timestamp of 155146 second. This is not a log in this boot. This was the log from the last time your xserver is running. That is why it gets closed in the end of the log.

Please use your tty6 to manually run gdm3 service and see if the desktop is back. If it still not getting back, check if the xorg.0.log gets refersh.

Also, please check if your disk space on jetson is full.

And this forum board is for TX2. Is your issue on AGX or on TX2?