Jetson IO doesn't work

When I ran the following code:
sudo /opt/nvidia/jetson-io/jetson-io.py’,
the UI flashed,but nothing is in it.


I dont know how to fix this issue, plus: Jetpack version:4.6.1.
Anyone help?

Are you using custom carrier board or devkit?

Sorry, I’m not quite clear about the difference betweeen the custom carrier board and devkit. At present, I only have the TX2 board.

Sorry, I’m not quite clear about the difference betweeen the custom carrier board and devkit. At present, I only have the TX2 board.

it looks like this, https://www.arrow.com/en/products/945-82771-0000-000/nvidia
Jetson-IO it only works with development kits, that’s why we’re asked.

Yes, the development kits u mentioned above are the device I use now.

hello user71691,

I cannot repo this issue,
is there anything pop-up by using up/down to select the options?

Nope, 2 options are avaliable, “Configure for compatible hardware” and “Back”
image
well. when I choose the configure for compatible hardware:
image
But I dont have the compatible hardware, and I’d like to set the pins by manual, howevr the option "configure for manual " disappeared!

hello user71691,

it’s Jetson-IO to check the pin groups to configure the pins.
how you flash the target? could you please re-flash with native JetPack release for confirmation.
please see-also JetPack Archive | NVIDIA Developer, thanks

sry, I dont think I have enough time to reflash tx2 board, because I install too much things on it, is there any other methodS to help initialize the 40 pins in TX2?

hello user71691,

it’s mb1 cfg file for pin init configuration.
may I know what’s the actual use-case, you may use sysfs to toggle the pin.

thx for ur reply, the actual use is I2S on jetson TX, but now I cant set the pins for I2S because the 40 pins is not avaliable for manual setting

hello user71691,

please have pinmux configuration applied by the software.
you may see-also developer guide for reference, Pinmux Changes.
thanks