Jetson nano pinmux

Hi,
I have tried sudo /opt/nvidia/jetson-io/jetson-io.py Initially I got the error message about line 25 as per page 1 of “Configuring the 40-pin Expansion Header”, so after doing the sudo find /… correction, , when I enter the original command I now get a brief flash on the screen(less than 1 second) of what seems to be the Jetson Expansion Header tool which then dissapears. There is no error message in the terminal, it just returns a new command line prompt.This was on the nano dev board version B01 with the rt-preempt patch.

So I tried the other method of generating a dtsi file in windows, then converting these on an unbuntu 18.04 amd64 machine using dos2unix, then generating a .cfg file. this was successfull although I had to leave out the version number from the command to get it to work as follows;
$ python3 pinmux-dts2cfg.py --pinmux addr_info.txt \ gpio_arrd_info.txt por_val.txt mandatory_pinmux.txt
tegra210-jetson_nano_devkit-pinmux.dtsi
tegra210-jetson_nano_devkit-gpio-default.dtsi \

tegra210-jetson_nano_devkit-pinmux-gpio.cfg

This results in a cfg file of about 350 bytes.

My questions are :
Have I made any missteps in generating the cfg file ?
Where/how do I put this cfg file on the jetson nano board ?
and
How can I fix sudo /opt/nvidia/jetson-io/jetson-io.py ?

hello preprec377x,

  1. may I know which JetPack release you’re working with,
    had you also check known issues and apply the fixes from Configuring the 40-Pin Expansion Header session.

  2. the steps to use pinmux customization and generate cfg files looks correct, you’ll need to perform a whole flash, i.e. $ sudo ./flash.sh jetson-nano mmcblk0p1 to update the board configuration files.

Hello JerryChang,
I havn’t been using JetPack, so on reading your post I started the SDK manager on the host and tried to flash the os drivers and applications. They downloaded to the host but they did not install on the target. It would be JetPack 4.4 DP. In any case I checked the link you gave me re “Configuring the 40-Pin Expansion Header” and noticed there are 2 extra fixes than in the 32.3.1 so I applied them and it works, success! thanks.

However I want to complete the spreadsheet method as it allows more options such as specifying the direction of gpio’s. Where should I put the cfg file before doing a whole flash ?

hello preprec377x,

Nano platforms use device tree settings to update board configuration. please overwrite default settings by customize files,
you may also refer to Topic 76221 for the steps to use the Jetson Nano’s Pinmux spreadsheet.
thanks

Hello JerryChang,
I have followed closely “Customizing_the_jetson_nano_40_pin_expansion_header_V1.2.pdf” mentioned in topic 76221 which I think follows the headings you outlined in the same topic. The host reports that the board has been successfully flashed, however the board is stuck on the Nvidia Logo and neither resetting or restarting it can get it to boot.

The l4t version on the nano is 32.3.1 and the board is b00 version. On the host I have used JetPack_4.4_DP_Linux_DP_JETSON_NANO. I downloaded and was going to use JetPack_4.4_DP_Linux_DP_JETSON_NANO_DEVKIT or JetPack_4.3 but neither of these have the folder Linux_for_Tegra/sources/u-boot/ for rebuilding the bootloader.

Can you advise me on how to proceed please.

Hello JerryChang,
I’ve got it now, thanks.