Jetson nano 2gb: Nov 3rd sudo upgrade and lightdm breaks

system: jetson nano 2gb devkit (brand new)

here are the repro steps:

  1. download jetpack 4.4.1 2gb and create new 64GB card.
  2. install SD card and boot nano
  3. complete initial configuration (language, keyboard, network, tz, user, 4gb swap, etc.) and device reboots.
  4. ubuntu login screen and successful login
  5. open lxterminal
  6. sudo update
  7. sudo upgrade
  8. sudo reboot
  9. nvidia logo. boot msgs. multi-user user login.
  10. blank screen. trying to start xsession.
  11. macbook is able to ssh into the jetson nano 2gb.
  12. sudo reboot. waiting for shutdown of lightdm with time counter. counter reaches 1:29min and then device reboots.

Excepted behavior is device shows GUI with login screen and then after login, the GUI desktop is available to access software.

As this is a basic operation, imagine this is affecting any new jetson nano 2gb devices recently shipped. Appreciate if someone could solve this issue.

Here’s what got upgraded:

Start-Date: 2020-11-03 18:04:29

Commandline: apt upgrade

Requested-By: user (1000)

Install: libllvm10:arm64 (1:10.0.0-4ubuntu1~18.04.2, automatic)

Upgrade: cryptsetup-bin:arm64 (2:2.0.2-1ubuntu1.1, 2:2.0.2-1ubuntu1.2), perl-base:arm64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), libpython3.6-minimal:arm64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), linux-libc-dev:arm64 (4.15.0-118.119, 4.15.0-122.124), xserver-common:arm64 (2:1.19.6-1ubuntu4.6, 2:1.19.6-1ubuntu4.7), vim-common:arm64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), xserver-xorg-core:arm64 (2:1.19.6-1ubuntu4.6, 2:1.19.6-1ubuntu4.7), libc6-dbg:arm64 (2.27-3ubuntu1.2, 2.27-3ubuntu1.3), libc6-dev:arm64 (2.27-3ubuntu1.2, 2.27-3ubuntu1.3), libwbclient0:arm64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.20, 2:4.7.6+dfsg~ubuntu-0ubuntu2.21), libsystemd0:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), snapd:arm64 (2.46.1+18.04, 2.47.1+18.04), libpython3.6-stdlib:arm64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), perl-modules-5.26:arm64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), sudo:arm64 (1.8.21p2-3ubuntu1.2, 1.8.21p2-3ubuntu1.3), gir1.2-accountsservice-1.0:arm64 (0.6.45-1ubuntu1, 0.6.45-1ubuntu1.3), libc6:arm64 (2.27-3ubuntu1.2, 2.27-3ubuntu1.3), libpython3.6:arm64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), python3.6:arm64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), xserver-xorg-legacy:arm64 (2:1.19.6-1ubuntu4.6, 2:1.19.6-1ubuntu4.7), udev:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), locales:arm64 (2.27-3ubuntu1.2, 2.27-3ubuntu1.3), gdm3:arm64 (3.28.3-0ubuntu18.04.4, 3.28.3-0ubuntu18.04.6), gir1.2-gdm-1.0:arm64 (3.28.3-0ubuntu18.04.4, 3.28.3-0ubuntu18.04.6), libudev1:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), libperl5.26:arm64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), python3.6-minimal:arm64 (3.6.9-1~18.04ubuntu1.1, 3.6.9-1~18.04ubuntu1.3), samba-libs:arm64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.20, 2:4.7.6+dfsg~ubuntu-0ubuntu2.21), xserver-xephyr:arm64 (2:1.19.6-1ubuntu4.6, 2:1.19.6-1ubuntu4.7), libgdm1:arm64 (3.28.3-0ubuntu18.04.4, 3.28.3-0ubuntu18.04.6), blueman:arm64 (2.0.5-1ubuntu1, 2.0.5-1ubuntu1.1), python3-cryptography:arm64 (2.1.4-1ubuntu1.3, 2.1.4-1ubuntu1.4), python3-distupgrade:arm64 (1:18.04.38, 1:18.04.40), libc-bin:arm64 (2.27-3ubuntu1.2, 2.27-3ubuntu1.3), chromium-browser:arm64 (85.0.4183.121-0ubuntu0.18.04.1, 86.0.4240.75-0ubuntu0.18.04.1), ubuntu-release-upgrader-core:arm64 (1:18.04.38, 1:18.04.40), libnss-myhostname:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), systemd-sysv:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), chromium-codecs-ffmpeg-extra:arm64 (85.0.4183.121-0ubuntu0.18.04.1, 86.0.4240.75-0ubuntu0.18.04.1), vim-runtime:arm64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), vim:arm64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), libpam-systemd:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), xwayland:arm64 (2:1.19.6-1ubuntu4.6, 2:1.19.6-1ubuntu4.7), distro-info-data:arm64 (0.37ubuntu0.7, 0.37ubuntu0.9), systemd:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), xxd:arm64 (2:8.0.1453-1ubuntu1.3, 2:8.0.1453-1ubuntu1.4), libgl1-mesa-dri:arm64 (19.2.8-0ubuntu0~18.04.3, 20.0.8-0ubuntu1~18.04.1), libsmbclient:arm64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.20, 2:4.7.6+dfsg~ubuntu-0ubuntu2.21), libmysqlclient20:arm64 (5.7.31-0ubuntu0.18.04.1, 5.7.32-0ubuntu0.18.04.1), libnss-systemd:arm64 (237-3ubuntu10.42, 237-3ubuntu10.43), ubuntu-release-upgrader-gtk:arm64 (1:18.04.38, 1:18.04.40), libc-dev-bin:arm64 (2.27-3ubuntu1.2, 2.27-3ubuntu1.3), multiarch-support:arm64 (2.27-3ubuntu1.2, 2.27-3ubuntu1.3), libfreetype6:arm64 (2.8.1-2ubuntu2, 2.8.1-2ubuntu2.1), ca-certificates:arm64 (20190110~18.04.1, 20201027ubuntu0.18.04.1), perl:arm64 (5.26.1-6ubuntu0.3, 5.26.1-6ubuntu0.5), libcryptsetup12:arm64 (2:2.0.2-1ubuntu1.1, 2:2.0.2-1ubuntu1.2), mesa-vdpau-drivers:arm64 (19.2.8-0ubuntu0~18.04.3, 20.0.8-0ubuntu1~18.04.1), accountsservice:arm64 (0.6.45-1ubuntu1, 0.6.45-1ubuntu1.3), chromium-browser-l10n:arm64 (85.0.4183.121-0ubuntu0.18.04.1, 86.0.4240.75-0ubuntu0.18.04.1), libaccountsservice0:arm64 (0.6.45-1ubuntu1, 0.6.45-1ubuntu1.3), mesa-va-drivers:arm64 (19.2.8-0ubuntu0~18.04.3, 20.0.8-0ubuntu1~18.04.1), tzdata:arm64 (2020a-0ubuntu0.18.04, 2020d-0ubuntu0.18.04), docker.io:arm64 (19.03.6-0ubuntu1~18.04.1, 19.03.6-0ubuntu1~18.04.2)

End-Date: 2020-11-03 18:07:26

Thanks!

Hi dpseattle,

Following your steps, confirmed I can’t reproduce issue.
After update, upgrade and reboot, the lightdm still alive without problem.
Please try again, if still get the same issue, please provide the dmesg for check.

Please directly try cold boot (remove cable/plug cable) and see if it can boot into desktop.

Cold boot - same result.

@carolyuu, did you test with a new 2GB kit w/ wifi dongle, and 2GB jetpack 4.4.1 (timestamped Oct 19th)?

Can I get a replacement? Really want to get into building on this board!

I captured the apt history log from yesterday and today and its changed for the good. nano2gb GUI is working!

here’s the side-by-side list:

apt_history.tar.gz (6.0 KB)

thanks for the help!

1 Like

Hi,

What did you change to make GUI work?

nothing. apt upgrade list changed from last night - it’s shorter list of packages. check the apt_history file to see the difference.

hence, software issue that jetpack OS release person fixed by removing or updating an offending 18.04 package. :)