Jetson Nano booting error(Black screen)

Hi Everyone.

I have some problems about booting Jetson Nano Developer Kit.
(I use 128GB micro SD card)
I was trying to install ROS in Jetson Nano. When I tried, I felt ROS is not properly installed in my Jetson Nano. So I decided to shut down and turn on it to restart.

When I turn on it, the screen goes black, and Ubuntu screen was not displayed in my desktop. This is my current Jetson Nano desktop screen.


I found a lot about this booting problem, but I can’t find a clear solution about this. I saw some solutions about reflasing SD card, so I tried it but nothing changed in my Jetson Nano.

I really need to solve this quickly because I have no time to delay the current work. Is there anybody who know the solution about this?

Thanks a lot.

Hi 2020130022,

Are you using Jetson Nano devkit with SD module?

Have you tried to re-flash the devkit with SDKM?
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

No I didn’t try this. Can I do like that in Jetson Nano?
I will try and let you know the situation!
Thanks


Now I found the dev/mmcblk0p1 is full. How can I clean this memory?

If you are logged in simply delete any files you don’t want. I would advise having at least a small percentage (even 1% or less, but something less than “full”) before trying to remove any packages. You don’t want temporary files filling it up in the middle of a package manager update. Serial console is an excellent way of doing this. You do seem to have login now, so I suggest starting with seeing if you have files you can remove from any of these locations (things not owned by a package):

  • ~/Downloads
  • /var/log/Xorg.*.log.old
  • ~/Documents