Not booting of the jetson nano after flashing

I recently bought a Limo from AgileX, that is powered by the jetson Nano 4GB. During the development there were files corrupted. I tried to reflash the sd-card, with the instructions from the developers AgileX, (unfortunately they are impossible to get in touch with). the link is heredocs. But if I install it and plug it back into the jetson nano, I got this error:


I have tried using a different SD-card and as well as the image from the official NVIDIA site. If I use that image, the first boot I got a desktop but saying, “The installer encountered an unrecoverable error. A desktop session will now be run so that you may investigate the problem or try installing again”, The jetson nano restarts but that is it. It doesn’t go into linux, and keeps having a black screen. Could any help me please because right now I have no idea what to do. There is a blue light that is turned on noth a green light

Please ask the board vendor to provide you the BSP and reflash the whole board again.

Your sdcard or board won’t work if you follow our guidance here. NV moderators here can only guide you to check the issue on NV developer kit.
Our software is also only for NV developer kit. For example, there is no sdcard on NV developer kit carrier board.

But obviously there is one on your carrier board according to your log.

Thank you for this quick reponse, So The problem is that AgileX is unreachable, and they have an image that can be uploaded on the SD-card. I have done that, but I got the same problem.
You mentioned that I need the NV developer kit, but I believe that it is what they provide to us, It is a Jetson Nano 4GB, and sorry I mean to say micro-SD card not a sd card. So I thought that would be the same.

How about you take a picture of it and I can tell you more detail?

Most of users don’t know what kind of board they are using.

Hi, I can’t really take a picture form it , but with the documentation of AgileX, they mentioned that they are using: NVIDIA Jetson Nano (4G) here is the documentation docs, And while working on it (before the crash) I found out that it uses the jetpack 4.6.

Hi,

I think you misunderstand something here…

This is Jetson Nano forum. So of course every question here is using Jetson Nano… What I said here is if your “carrier board” is not NV developer kit, then software provided by NVIDIA won’t work on it.

For example, if your carrier board has sdcard slot (no matter micro SD or SD), then it won’t work. Our default software does not enable sdcard slot on the carrier board.

Your so-called “doc” already revealed that one is not NV developer kit…

Hi,

Thank you for the clarification, do you know where i could post my problem then? Or isn’t there a forum for it?

Sorry, I don’t know. This is not what NVIDIA can help.

If you work on NV developer kit, then we can tell you how to totally reflash the board.

Thank you for your feedback I understand that you can’t help with it.
I have tried to follow the steps on the site of “get started with jetson nano developer kit” where they use an sd card as boot drive but that won’t work anymore as you mentioned.

Sdcard image does not really reset the board status. There are some software running on the QSPI flash on the module itself. In your case, linux kernel is even on the emmc but not your sdcard.

Actually the full reset of the module requires another ubuntu 18.04 host x86 PC and running sdkmanager to flash your board.

Is there a site where the that information is on and some kind of tutorial for it that I can try and follow?

https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3273/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/quick_start.html#

Again, this tutorial is based on NV devkit. It is very likely some pins do not exist on your side…

Hi, So after reflashing the jetson nano, I got it working again but now the sdcard from the jetson isn’t detected, can you help me with that? thank you, Because right now the storage is full. This only happens when the sd card is directly connected trough the onboard sdreader, if I use a usbadapter it is fine.

Hi,

Actually this is just as my prediction here… nothing I can help. The board vendor shall provide the guidance.

Yes, found it also out that they are responsible for this part. I will try to get in touch with them but thank you for your help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.