Jetson Nano booting screen problem/imx219_board_setup: error during i2c read probe

system info:
SanDisk 32GB sd card
WaveShare JETSON-IO-BASE-A base card

hi, since the first image in my sd card was able to use just 14 GB of my total space, I wanted to resize the partition and I did so by using Gparted. After I inserted the sd card into the Jetson Nano I had a screen like this(photo). And after that, a whole blank screen. I thought it was because of my sd card and change it, then I flashed a jetpack image multiple times. but nothing changed. Now I cannot use my Jetson Nano. Can you help me, please?

Hi muhammedtasgin61,

Why your SD card is 32GB, but you can only use 14GB?

Does your board could boot up before?

How did you do this?
Could you help to provide the flash log for further check?

when I searched for this storage problem, I saw a response explaining that the image in the “getting started with jetson nano” may cause this kind of problem. And the solution was to resize it after flashing it. I used Etcher to flash the image. By “I flashed a jetpack image multiple times” I meant flashing the image over and over to make sure that it was not a problem with the image.

For the first time, I booted it and it worked. I never did it since this time.

I didn’t understand the “flash log” part. I m pretty new to these electronic things really sorry :/

But I can say something that may help. I wanted to use the board’s pins as SPI pins. But I noticed that I cannot do it directly. So I found something which adopts my GPIO pins as SPI pins. But the size of the needed files was too much so I had an issue with storage. And the story began like this. I tried to resize my storage and everything happened accordingly.

You are using the board customized by Waveshare.
Please ask your vendor for BSP package and use to flash your board.
The common command for flash as following

$ sudo ./ <config> mmcblk0p1

After you run the above command, the flash logs would showed on the console of your host PC.

For this purpose, you might need to refer to the schematic of your board and update pinmux.
What’s your Jetpack version in use?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.