Jetson Nano Devkit Unresponsive

I have a Jetson Nano Devkit (P3450, official NVIDIA version) that I bought a few years ago, but didn’t use. Recently, when trying to use it with the standard Nano firmware through the SD card image, the device did not respond as it should when booting. The green onboard LED indicates power, and sometimes the RJ45 connector has solid green and orange LEDs lit up without interacting with the port at all. However, most other parts of the device are not working.
Multimeter testing reveals that at least the 5V and 3V pins on the GPIO grid provide power, however, USB ports do not seem to be providing voltage, and the top of the module heatsink is not warm as it would be expected to be as a result of normal activity. When plugging it into my computer through the microUSB port, the device shows up as named ‘APX’, and properly sends the NVIDIA vendor ID. Most importantly, the HDMI jack does not show visual output after the imaged card is inserted into the module. I first tried to reflash the device with SDK Manager using an Ubuntu 16.04 VM (I have heard that VMWare is the best for this), since I don’t have a native Linux environment. The firmware was able to be downloaded, and SDK Manager detected the presence of the Nano when it was plugged in. The problem was that after reaching ~99% installing, the flash fails with error message

Error: Return value 1
Command tegrarcm --download ebt cboot.bin.encrypt 0 0 --download rp1 tegra210-p3448-0000-p3449-0000-a02.dtb.encrypt 0
Failed flashing t210ref.
*** ERROR: flashing failed.

I also tried redownloading the firmware package and flashing with, with the same result. I’ve also used a few different power sources and USB cables, so that’s not the issue. Finally, I used a USB to UART module to open the serial console on the Nano. However, when doing this, I get no response on any environment that I try to use PuTTY, Picocom, or the Python JN UART executable on. That is; there is no response over serial of any kind (and I have validated that the USB-UART module works).
Is there anything that I would be able to do to test or repair the device that I haven’t thought of? And if it is a hardware issue, is it something that I can identify and fix, or is there a way that I could send the device off to be repaired?
Thank you.

The “APX” tends to mean you are using a VM. VMs do not work right unless you get lucky. Before I say more though, I’ll regress and provide some background.

Jetsons (and many embedded systems) do not have an actual BIOS. That means that the equivalent is in partitions. For a Nano SD card model, that’s in QSPI memory which is part of the module itself. The boot content is also on the QSPI for that model. That content must be compatible with the software release which the operating system uses (the rootfs on the SD card). If you have an older system, then it implies the module content very likely has to be updated to use a newer SD card software. To do this, you must flash the module itself.

In the case of the APX, this gets inserted in VMs. During any flash the USB will disconnect and reconnect. Even if a VM works correctly initially, it is quite common for them to lose the reconnect. That’s a configuration issue of the VM, and each VM has different instructions. It isn’t possible for the flash software to “fix” that…it is up to the end user. So VMs are not officially supported. You might be able to get it work, or you might just get lucky initially. Furthermore, if you use the WSL2 VM, you have to be sufficiently advanced in its configuration to add loopback (a new kernel) ability before any rootfs image can be generated (pregenerated binary images might work without that).

You are advised to give up the VM. A native Ubuntu 18 is your best bet for flashing a Nano.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.