Jetson Nano does not appear as a USB device on host PC

Hi everyone.

I’m trying to install a newer version of L4T on my Jetson Nano and I was planning to do that through the SDK Manager on a host PC (running Ubuntu 18.04) but it cannot detect the Nano when connected via micro-USB. I use lsusb to see all connected(?) USB-devices but it does not appear. The number of devices does not even change when checking with it plugged or unplugged. If I unplug my mouse-dongle, I can see “Logitech” disappear if I run lsusb with it disconnected, and appear when it’s connected.

I’ve also tried different cables to connect the Nano, but all it does it power it.

The Nano has been flashed with an Ubuntu 20.04 image. I have understood that it’s possible to flash a Jetpack image on an SD card to then plug it into the Nano, but this is nothing I have done since I am concerned about “overwriting” the previous image (I am verrrrry new to everything regarding Ubuntu, Jetson)

Recovery mode is not something I have used, since the data on the Nano is not of great importance.

Grateful for all answers!

Please refer to steps in
How to Put NVIDIA Jetson NANO in Force Recovery Mode? - #2 by WayneWWW

After Jetson Nano goes to recovery mode, you can flash it through SDKManager.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.