Jetson Nano is not working. The Green LED blinks and turned off within 2 sec

Hello Team

My Jetson Nano 2GB DevKit which is a very new one (TF version). I flashed the SD card for the first time and the initial configuration were done and I verified with DP which was successfully booted up. Then i unplugged the the SoM from the DevKit to plug it on my Jetson MATE as worker slot it doesn’t light ups which indicate it doesn’t work. Also tried with master slot it wasn’t worked.

To confirm the behaviour, I revert everything back to the DevKit as it like first time. Unfortunately it shows green LED for 2 sec and turned off !!!

Power Supply I given were 5v-4A (and also tried 2A)


  • Jetson Series : Jetson Nano 2GB DevKit (B)
  • DevKit Model : P3450
  • SoM : Jetson Nano (B01)
  • SoM Model : P3448

I tried to debug with the TTL, console prints
jetson-log.txt (4.5 KB)

I also referred lot of topics with same issue none of them were given solution !!!

Thanks in advance :)

Please first try to re-flash the device with SDK Manager first.

I tried with the SDK manager it showing error on flashing OS and on others too !

After a lot of Debugging I found the solutions by flashing Uboot on the DevKit. I Just followed below article to solve this issue.
Flashing Uboot/firmware (

Thanks for the reply

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.