Jetson nano not displaying anything

Jetson nano when connected to monitor doesn’t output anything, I have followed all the steps given on getting started with jetson, flashed the card and mounted the card on jetson, I am also using 5v/2A supply but still there is no output, I also tried 5v/4A through dc jack but still, no output.

Please at least re-flash with SDK Manager.

Does it have onboard emmc storage like seed studio? Do I have to insert memory card and then use SDK manager?

Is the SD card on the module itself or on the carrier board?
If it’s on the carrier board then that means it’s a custom carrier board, and please ask the vendor for help.
If it’s on the module itself then that means it’s a DevKit, and please re-flash with SDK Manager.

The sd card mount is on the module and not on carrier board, when I connect jetson to sdkm it detects the board but shows no os to install and after installation of host prerequisite nothing happens. I am using ubantu 20.04.

You need to use Ubuntu 18.04 instead.
Or directly flash with our BSP:

1 Like

It worked!!! I used 18.04 on VM and the module was detected, I used SDK to flash and everything looks ok now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.