Issues connecting jetson nano in headless mode

I have a 4GB jetson nano and I am having problems setting up the jetson nano. I’ve flashed the image on a sd card and inserted it in the nano and powered it with a DC supply of 5V- 2A however, when I open my device manager, I don’t see a port showing the nano is connected. Without the port, I can’t connect use the nano via putty on my computer. I’ve also tried connecting a monitor, keyboard and mouse for display however the nano is not outputting anything on the screen. The steps I followed for connecting are the steps provided by nvidia.

Does anyone know what the possible issue is?

Hi akashsivapalanspam,

Are you using the devkit or custom board?
What’s the OS of your host PC?

I am using Windows on my PC and I am using the devkit.

How did you flash SD card?

The devkit should be booted up successfully from manufacture state.

If you get any boot up issue, I suggest you re-flash the devkit through SDK Manager,
but it is only available on Ubuntu.
You could refer to the following link for installing jetson through SDK Manager.
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

Try what @KevinFFF sayd first,
and the try this too.

You may figure out most of booting issues with this.

1 Like

Hello @KevinFFF , I tried using the SDK manager on a ubuntu VM and on the first step, it says “No available releases for host OS: Ubuntu 20.4”. Do you know if I need a specific ubuntu version? Thanks.

It depends on which Jetpack version you are going to flash.

  • Jetpack 4 Ubuntu 18.04/16.04
  • Jetpack 5: Ubuntu 20.04/18.04

As a result, I think Ubuntu 18.04 would be better for your case.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.