Jetson Nano Power Button Issue


I would like to have a power switch for my Jetson Nano A02. For that,

  1. Short the J40 7-8 pin.

  2. Add a push button switch to J40 1-2.

— First Try —

  1. Now I connected my adapter (5V 4A) to the AC power, switch ON the AC power.

  2. Push the ON button on Jetson I just connected.

Jetson didn’t turn ON.

— Second Try —

  1. Now keeping my adapter turn on, I unplugged the adapter from jetson (barrel jack) and plugged it back.

  2. Push the ON button on Jetson.

Jetson turned ON.

Each time when I shut down and turn the AC power OFF, and then restart the AC power, Jetson stops turning ON. For restarting, I’ve to unplug the barrel jack and reconnect it physically. Because of this problem, I can’t use the Jetson for a project. Because each time the power goes, I’ve to go to Jetson and do this unplugging and plugging again.

Anybody have noticed this behavior?

Are there any remedies for it?

Any help is greatly appreciated.

Did you try other power supply as this? In general, it should be same between turning on/off AC power and plug/unplug it.

I’ve tried a 5V 4A adapter and well as another power supply. I was able to reproduce the same issue in both cases. Now planning to set up a push to off switch to replicate the unplug/plug action. That is, on powering up if the Jetson doesn’t boot, push to off switch will be applied.

I remove all the previous setup. Now,

  1. Auto On is not short J40 7-8
  2. No push to ON switch on J40 1-2

This is very interesting. I can’t turn Jetson on if I plug and unplug the adapter end. But it is possible with the plug end of the adapter. Is this because of some capacitor-discharge issue? I could reproduce the same issue on the versions BO1 and AO2.

It looks like problem of capacitor in adapter, can you try other type of power supply, such as DC power supply? That should be able to verify if it is the cap issue of adapter.

I could reproduce the issue on a DC power supply and an adapter. Solved the issue using a push to off switch. And for checking your resolution, I bought a new adapter and it seems to be working normally. Maybe it was the old adapter issue. Now Jetson Nano turns ON every time power is up.

Thanks for your response.

NB: If NVIDIA can enlist the accessories along with Jetson, these confusions could be avoided.