Jetson nano stuck with NVIDIA logo at boot

I started to work with my ne Jetson Nano 4GB. Somehow now it is booting with the NVIDIA logo, but no Linux boot afterwards. Any way to control/debug before I reformat the SD card?

Yes, please try to dump the log from uart serial console.

Until I get such a cable (it needs to be 3V, not 5V). I tried with a new SD card and the system works fine. So I assume something was damaged with the SD Card.

Wish the Jetson Nano had built-in 128GB flash

Just to update that the problem is with the SD card - it got corrupted. A new SD card is working well. However, I couldn’t fix the damaged card with several Windows applications. I would appreciate any idea how to fix it? before I throw it away. Any Linux fixing util?

I don’t think there is ever a solution for fixing a sdcard. Actually, we only heard some users say few sdcards are not compatible with jetson nano sdcard image. But they are not “damaged”.

Also, we usually use the log to tell what is going on for each error. Based on the info we received on this thread so far, we still have no any idea about your problem because there is no log.

The file system of the SD file was fully corrupted, so no access to files on it. I tried several “rescue” software, but all failed. This SD card was working for 2-3 weeks. Now I am using another one for 3 weeks, so far working well.

couldn’t fix the damaged card with several Windows applications

Are you trying to fix the corrupted filesystem but not re-install them?

In order to re-install I need to re-run the SD card formatter, right?
I tried the quick format and the “overwrite format” - in both cases I got “formatting failed”