Jetson Orin is shutting down itself permanently after some time


I have a few Jetson Orins. I am using a docker image to run my custom scripts, DWS to remote access, and crontab jobs to connect to the internet via Simcom Wvan Sim 7600x automatically.

No matter what I do, I lose connection to the device after some duration. The device is trying to reboot itself, but it’s not going online.

I didn’t face the same issue on Jetson NX or Nano. When I moved the device’s SD card to another Jetson board, the new board was also not working. When I reinstall the device by using Jetson SDK, it works. After a while, I am still losing the device.

I think two days ago, I lost the 5th device; what could be the reason? Does the Jetson Orin have a chronic issue that might cause this?


We didn’t receive any other report for such issue on Orin AGX before.

To identify what happened, I think you could enable the serial console log and see what happened.

BTW, are we talking about a “shutdown” or “reboot”? A software error will only trigger “reboot” but unlikely to trigger a “shutdown”.

I am still not sure about what’s happening. I got more information from our team about the issue. In this particular case, we lost connection to the camera, which is mounted on the device. After that, we restarted the device, but it never booted up again.

It should be a shutdown because the fan connected to the device stopped working, like the power is completely shut down.

I tried to restart the device many times manually, but it’s not responding at all. When I replaced the SD card, everything worked fine so the power source should be fine.

I activated the serial console as you described, and it worked, and I have connection to the device. However, it’s not throwing any errors. I tried to go to the following path to check the logs cd /var/log, and I received the following line -bash: cd: log: Structure needs cleaning.

This is the output I saw as soon as I logged in to the device:

> Welcome to Ubuntu 20.04.6 LTS (GNU/Linux 5.10.120-tegra aarch64)
>  * Documentation:
>  * Management:
>  * Support:
> This system has been minimized by removing packages and content that are
> not required on a system that users do not log into.
> To restore this content, you can run the 'unminimize' command.
> Expanded Security Maintenance for Applications is not enabled.
> 171 updates can be applied immediately.
> 124 of these updates are standard security updates.
> To see these additional updates run: apt list --upgradable
> 38 additional security updates can be applied with ESM Apps.
> Learn more about enabling ESM Apps service at
> *** System restart required ***

How can I get more information from the device? The strangest thing is that I didn’t change anything about the custom scripts I implemented. So, while the device was in operation, suddenly, I lost the device, and this kept happening.

Please really try to use the method I provided to dump log from micro usb port (if this is NV devkit).
Using syslog or /var/log do not help clarify anything. syslog does not record the error log but my method from micro usb port will.

Your method to tell a board is shutdown or reboot is not correct either. No one can judge the board status by checking the fan is running or not. I can create a situation that the fan is not running but board still powers on.

Also, are you always booting the jetson from a sdcard?

It should be the dev-kit. I couldn’t see anything after using the following command minicom -D /dev/ttyACM0 -8 -b 115200. I connected the board to the laptop via type-c. This is my device:

I just lost another Jetson Orin which was created from a backup point of the previous device. It didn’t come back after I ran a reboot command.

Yes, we are always booting the Jetson from a sdcard.


Just to clarify.

You are posting a topic in Jetson “AGX Orin”.

But the board picture you posted is not a AGX Orin. It is more like a Orin Nano or NX…

Thus, when you followed my method to dump log from micro usb port, of course it will not work because that is not for your board…

Please try to understand what yourself is using and file in correct forum…

1 Like

Sorry, there are too many Jetson models. Sometimes it’s hard to keep track of it. At least we know the board now. Thanks, I am creating another topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.