Jetson orin nano - can't boot

Hi,

So I had a jetson orin nano sitting on my desk and decided to get back into it. I decided to re-flash to get a new start. But I can’t seem to get it to boot anymore. It gets past the bios, but then screen just goes blank.

I’ve tried using Jetpack 5.1.1, 5.1.3, and 6.0.

I was able to capture the attached from the serial console. It looks like the card isn’t mounting maybe?

Any ideas?
Welcome to minicom 2.txt (129.7 KB)

Hi pquack,

Are you using the devkit or custom board for Orin Nano?
Which Jetpack release would you like to use?

How did you flash the board?

[    8.476566] Mount initrd as rootfs and enter recovery mode                   
Finding OTA work dir on external storage devices     

From your log, it seems you boot into recovery kernel.
And it seems trying to perform image-based OTA.

Hello pquack,

I had the same problem in my Jetson orin nano devkit.

All you have to do is just reset all your boot parameters and reboot.

Normally it should work!

I didn’t flash the board… this is the board that came with the jetson nano.

How do you do that? When I press Esc during boot, nothing happens.

Can you take a photo of the last thing you see on your screen?

Are you using the devkit or custom board for Orin Nano?
You said that you tried different Jetpack release.
How did you switch those releases?

This is the devkit board that came with Orin Nano when I bought it. It’s not custom.

I’m using balenaEtcher to flash the different versions. It won’t boot on any of them.

After this, screen goes blank.

It’s really weird that nothing happens when you press esc (because it’s marked on the upper left screen!).
When you want to put the image on the sdcard, do you format it or not?
Try to boot it without the sdcard and screenshot the result.

Could you try using SDK Manger to flash your devkit?

Without the SD card, I can eventually get to like a recovery command line… keyboard works there. Keyboard is usb. Not a lot I can do at that command line, however.

Well I figured out how to get the SDK Manager installed (Its unfortunate you have to install Ubuntu… that took me some time to overcome). It fails when I try to flash.

I’m using Ubuntu 22.04. A small difference is I only have a 2019 Mac, so there are some modifications from a vanilla install I have to do.

SDKM_logs_JetPack_6.0_(rev._1)_Linux_for_Jetson_Orin_Nano_modules_2024-06-09_06-37-37.zip (350.6 KB)

Do you connect the NVMe SSD on your devkit?
If not, it seems expected to enter into UEFI shell since there no available boot device on your board.

Are you using x86 based Ubuntu host? Or ARM based?

Hi. So I figured out a workaround. I installed Ubuntu directly following this. Then it worked.

https://ubuntu.com/download/nvidia-jetson

(No offense, I like their instructions better. Much simpler process.)

Okay, that is supported from JP6.0GA (R36) which come with Ubuntu22.04.