Jetson Orin Nano stuck at first time boot


I purchased a Jetson Orin Nano Developer Kit. Following the steps on I flashed a 64 GB Sandisk SD card.

On powering up using the given adaptor, the green LED and fan turn on and Nvidia Logo appears on the screen with options to enter boot manager. It attempts direct launch, but a black screen appears and fan turns off while the LED remains on. However, it shows messages on the serial console. The log is below.

orin_log.txt (85.1 KB)

It is repeating the same lines again and is stuck at the same point for over an hour. I am not sure if it will take this long as I remember Jetson Nano had very less booting time (even the first time). Should I reflash the SD and try? I downloaded the image from

Re-flash the device with SDK Manager.

I reflashed the device, and the installation completed successfully. When I try to access via the USB-C serial port, I get the below message.

I don’t have access to a monitor now, I will update the same by tomorrow. Any inputs on what is wrong?

Are you sure you are using everything default from NVIDIA?
Delete the BSP on your host PC and download/flash again.
Something in the BSP is missing.

orin_log_aftersdk.txt (77.3 KB)

This is the serial console log, can anything be inferred from this?

[ 29.714698] Please complete system configuration setup on desktop to proceed…

It means everything is fine.
You just need a monitor to complete the OEM config.

Should the jetson be in force recovery mode for this or the jumper can be removed?

It can be removed.

Is there a guide for oem-config? The link given in Jetson Orin Nano Developer Kit User Guide - | NVIDIA Developer doesn’t work.

Connecting to desktop shows the NVidia logo, I pressed Esc to enter boot manager and select the SD card as boot device. It shows attempting direct launch and the screen becomes black after some time.

The log is attached.
orin_log_desktop.txt (40.3 KB)

The fan remains on and the led is also on. I have connected a HDMI display, USB keyboard and mouse, and an ethernet cable.

Then do this and flash again:

It worked, thanks.

I followed the above link and also changed the OEM-config option in the dialog box showing up as “Runtime”.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.