Jetson TX2 Crash CAN BUS without initializing the driver

Please tell me, if you turn on the Jetson power, it starts to destroy the CAN at speeds below 500k , if you initialize the driver in the system, the problem completely disappears. This behavior makes it possible to no use Jetson in existing CAN networks, JetPack last.




after activating the driver, everything immediately becomes fine:
sudo modprobe can
sudo modprobe can_raw
sudo modprobe mttcan

ip link set can0 up type can bitrate 250000

I have tried various transceivers(MAX3051, MAX14882A), when initializing the driver I can receive and receive messages , everything works fine , but as soon as I restart Jetson the active bus collapses , until the moment I initialize the driver. It breaks the Jetson bus, how to fix the problem, how to silence TX Jetson before initializing the driver without using SHDOWN

Hi novikov_ilya,
when you are using 500k and above, is the bus working fine when you reset jetson untill reload driver?

When using 500k and 1000k, the bus does not break for some reason , but as you can see from the picture I sent you , the error signal on the TX line is also present ! I just checked CAN on Jetson xavier NX , there is no similar problem there !
Maybe you need to edit the kernel ? Any suggestions ?

which jetpack version you are using?

JetPack_4.4.1

The problem was never solved. Does anyone have any ideas ??