Jetson TX2 keyboard issue when using USB hub

So I actually found this same problem in another thread, but it was never answered:
When I connect my keyboard via a USB hub to the single USB3 port of the Jetson TX2, the keyboard starts making weird things. Hitting a key will oftentimes not do anything, then suddenly I get a continuous output of a letter in my terminal. Basically, it is impossible to control the TX2.
Note that mouse and cameras that I also connect via the hub are working fine. The keyboard is working fine when connected directly via the USB port. It is not working properly whenever connecting via the hub (no matter if other devices are connected at the same time or not).
I have Jetpack 4.4 installed with Ubuntu 18.04 and I flashed it using the SDK manager.


Have you tried other hub or keyboard? When this error happens, do you still see power indicator on your keyboard (if it has one)?

Just a thought about this, which also suggests what @WayneWWW says, to try a different HUB: A “transaction translator” (“TT”) is used to adapt lower speed devices to higher speed USB lines (via a buffer), but not every cheaper HUB has one for every USB port. I could see a HUB with single TT or no TT having problems when mixing higher speed devices and lower speed devices, or even if the TT buffer just being small (e.g., buffer overflow or underflow).

It could also be a signal quality issue for the keyboard and HUB (before ever reaching the Jetson).

If you monitor “dmesg --follow” and have the problem occur, then there also might be a log message you can see. Either way I’d still suspect needing to use a different model of HUB, but it would be useful to know if there is a dmesg log showing an error.

I tested the “ dmesg --follow ” command it showed the log message, seemingly with no errors.
Then I tried a different HUB model and indeed it worked with that other one.