Keyboard doesn't work + No display if SD card is inserted

I’m able to power on the Jetson TX2 and see the Linux screen. No errors are shown (just a bunch of [OK]s on startup, and then the Ubuntu screen waiting for keyboard input).

See image: https://i.imgur.com/j2E5PVZ.jpg

But I cannot enter anything, because the keyboard doesn’t work. We’ve tried several different USB keyboards, and connected the micro-USB to several different power sources, all of which are 5V+.

See image: https://i.imgur.com/V09AyNU.jpg

We’ve also tried doing a manual reset, holding the recovery and reset buttons as instructed. The system restarts but no new results.

Anything else we should try?

The first image is from a TX2 which is new and has an o/s on it, but was not yet flashed to a recent release.

The micro-USB is not normally used to power a TX2 (I suppose some third party carrier boards may do this, but I have not worked on any). Have you used the full-sized USB connector for the keyboard?

FYI, recovery mode boots the TX2 into a special custom USB device mode, but unless you flash this doesn’t actually change anything. Rebooting after being in recovery mode implies an unchanged system.

Now for the case of a custom carrier board the default operating system will have several parts of the hardware fail until you’ve told the Jetson about how various hardware is routed on the different carrier board. This is done through the device tree, and the carrier board manufacturer will provide this as a “board support package” (“BSP”). If the flashed system does not have the customization to work with the different carrier board, then this would be the reason for the keyboard failing…you’d have to flash the BSP.

Note that each BSP is for a given JetPack/SDK Manager release, so you’d need to find out what the latest release the carrier manufacturer supports, and then flash with that JetPack/SDK Manager release after applying their BSP to the install software. A Jetson in recovery mode is capable of being flashed.

A list of JetPack releases:
https://developer.nvidia.com/embedded/jetpack-archive