USB port inactive after flashing Jetson TX2

I am using Nvidia SDKManager to flash a Jetson TX2 on the Nvidia carrier board. After the OS is flashed my TX2 boots up and takes me to the System Configuration window where I am prompted to accept the ‘L4T_End_User_Licence_Agreement’, but as the USB port does not work I cannot interact with the jetson at all.

I can confirm it is not a hardware issue (My carrier board USB works with a TX1. I have tried multiple working USB mice and keyboards that all work fine on other devices).

There does not even seem to be power to the USB port as my USB device power LEDs do not turn on either.

I have no way to accept the terms and continue with the TX2 setup.

How can I fix this issue?

Is the carrier board the development kit board? Other carrier boards require a board support package change (mainly device tree) specific to that carrier board.

I am using the development kit board.

Is the TX1 carrier board from an earlier release? I do not know where the revisions are listed, but the original TX1 carrier board was lacking some wiring which the TX2 dev kit added. Later on I believe both TX1 and TX2 carrier boards all had the same wiring, but it is possible you are running into a carrier board with early enough revision that the TX2 USB might fail.

Would anyone know how he could check revisions on the carrier board to know if some part of the TX2 would not function on that carrier board?

I got the carrier board second hand so I don’t know its age or release version.

I did some other tests and discovered a sort-of work around:
Previously I was attempting to flash with Jetpack version 4.2.3 and 4.2.2, both of which resulted in USB failure.

It appears that if I first flash the TX2 with Jetpack 3.3 via command line script
sudo ./ jetson-tx2 mmcblk0p1

THEN reflash it using the SDKManager with Jetpack 4.2 it all seems to work. I have no clue why this works, but have repeated it a few times successfully.

It’s not a perfect solution as Jetpack 4.2 doesn’t include DeepStream or TensorFlow, but it’s good enough for me to consider my problem solved.

Link to a related issue
I’ve been encountering that this solution also seems to fix.

Thank you for helping to investigate.