Keyboard issues when using TX2 flashed by Jetpack 4.2

Hi, anyone faces issues with keyboard when using Jetson TX2 flashed by Jetpack 4.2? When I press a key either dozens of them entered or on the other hand I need to push it several times to type a letter, any similar issue and propably a solution? Many thanks.

Hi Mbinnova,

Are you means UART not working? or when you doing init process setup setting, the keyboard not working?
For JetPack-4.2, the first boot up, you need setup init process (like: username, password, timezone…)

init process worked and everything seems to be installed correctly. The issue is that when I type anything using my keyboard it doesn’t work or instead it types one letter several times although I just pushed that key only once. Yes it looks like UART issue. Any solution for that?

hello Mbinnova,

please share your environment setups, may I know which port you’re used to connect a keyboard?
thanks

I am using a USB hub having a mouse and a keyoard connected to it. USB hub is connected to USB 3 port of the board.

Hi Mbinnova,

If you unplug and plug-in USB hub, is it working?
If still not working, please share your UART log. Thanks!

Thank you. It seems we need a replacement for the kit as it stopped working. I will get back to you if we get same issue with the new board.