Jupyter lab on jetbot not responding

I cannot consistently connect to the Jupyter lab server on my jetbot.

It has worked a few times and I have executed most of the notebooks in the tutorial but I cannot connect to it consistently, even after a fresh reboot.

I can ssh into my jetbot from my laptop but I get no connection when trying to connect through my laptop’s browser. IP address and port are correct and jupyter lab seems to be running on my jetbot:

jetbot@jetbot:~$ ps -ef | grep jupyter
jetbot 3084 2119 0 22:41 pts/0 00:00:00 grep --color=auto jupyter
jetbot 4047 1 0 20:47 ? 00:00:00 /bin/sh -c jupyter lab --ip=0.0.0.0 --no-browser
jetbot 4091 4047 0 20:47 ? 00:00:10 /usr/bin/python3 /usr/local/bin/jupyter-lab --ip=0.0.0.0 --no-browser

Any suggestions as to how I can further dignose the issue?

I could connect the jupyter, but I failed to log in using my password

My steps as below according to https://github.com/NVIDIA-AI-IOT/jetbot/wiki/Create-SD-Card-Image-From-Scratch
1.

2

fciampoli,

Is there any chance you’re connected to multiple network interfaces (ie. eth0 and wlan0)? I’ve noticed before that Jupyter will only respond to one interface.

teslalady,

The Jupyter notebook password will be set to whatever is specified after following the prompts from this command

jupyter notebook password

You could try calling this from a terminal on your Jetson Nano to update the Jupyter password.

Please let me know if you run into any issues!

Best,
John

If I understand correct, both Jetson Nano and Linux laptop have to be on the same ethernet network?
What if laptop is on WiFi, since ethernet connection is rarely in use nowadays?

Not necessarily. You could forward a port and connect to it over the internet but that’s silly dangerous with jupyter.

If you want to connect your laptop to the Nano over short distances, it might be easier to set the Nano up as an access point and then connect to it. These instructions should work.

Thanks for your quick replay.
I founded it easier to plug monitor and keyboard to Jetson Nano and run Jupiter from command line directly.
Still couldn’t get it as “easy plug and play” of Jetson and Laptop as it shown on their video :-).

What browser are you using? I’ve noticed that IE won’t correctly pass my jetbot password through Jupyter notebook. When I used chrome, everything worked as advertised.