Jupyter notebook widgets not displaying

I have a Nano with a fresh Jetpack 4.5.1 on and Docker container l4t-ml:r32.5.0-py3. When i use widgets like:
import ipywidgets as widgets
Instead of a slider I get:
I have tried to follow some of the proposals at https://ipywidgets.readthedocs.io
This does not give any result. Have anybody else seen this behaviour? Any suggestions for how to solve this?

Hi @olasalte, are you assigning the widget to a variable? I think Jupyter is printing out the object, which is the default action when you have a free-standing value in a cell. Also I think you need to call display() on the widget.

Can you try something like this?

from IPython.display import display
widget = widgets.IntSlider()

Thank you for the reply. The result is the same

OK, I found that the nodejs installation needed updated in that l4t-ml container. I just patched the Dockerfile here in commit 77fecc. If you don’t wish to rebuild the container, you can update your container by running the terminal commands below inside the container.

Before running the commands below, if JupyterLab server is already running, stop it by going to File->Shut Down

# update nodejs / jupyter-widgets
apt-get update && apt-get install -y curl
curl -sL https://deb.nodesource.com/setup_10.x | bash -
apt-get update && apt-get install -y nodejs
jupyter labextension install @jupyter-widgets/jupyterlab-manager

# restart JupyterLab server
jupyter lab --ip --port 8888 --allow-root

If you wish to save these changes to the container, you can use docker commit

Thank you dusty_nv. This solved the issue.