keey in recovery mode while using SDK Manager

Tx2 kept in revoery mode at STEP 03 (completed system configuration) of using SDK Manager 0.9.11x.
Even we powered off Tx2 and powered on without set recovery mode.
As the USB cable is connected and at STEP 03 , SDK Manager always showed “Jetson device is in recovery mode.”

We went back and forth to remove and plugin the USB at STEP 03.
While the usb cable is plugged in, SDK Manager showed “Jetson device is in recovery mode.”
only unplugged the USB cable, SDK Manager showed message below.
"Could not connect to the target device. Verify that:

  1. The device is connected to this host machine with a USB cable.
  2. Ubuntu ‘System configuration wizard’ is completed on the device.
  3. Jetson’s Ubuntu OS is up and running."

Unfortunately, after plugged in the USB cable, SDK Manager showed “Jetson device is in recovery mode.” again.

We found this issue as we installed TX2 or Nano, moreover, no matter we selected automatic setup or manual setup.

Is there any we missed?

Thank you for any advice,

jp42_auto_1.png

Hi HuiW,

After flashing and Jetson device booting up, usb-device mode is up . The expected results at this stage:
Jetson device : 192.168.55.1
Host machine: 192.168.55.100

Please confirm if the two conditions are true on your Jetson device and your host PC.

Hi Carolyuu,

Thank you for your prompt support.

The result is not as expected.

Jetson device : 192.168.55.1 — yes
Host machine: 192.168.55.100 — no – 172.16.8.59

Thanks

Hi HuiW,

Your case is the same with this topic:
https://devtalk.nvidia.com/default/topic/1050668
It should be your usb-ethernet network interface is disabled on host machine, please to enable it.

Hi Carolyuu,

Thank you for your support.
Is there a way to enable usb etherent network interface on Ubuntu 16.04?

Thanks,

Hi HuiW,

Enable usb ethernet network:

  1. Disconnect and Connect the USB cable connecting the jetson and Host-PC, and check the dmesg log.
    You might see a log similar to this:
    [107833.388835] cdc_ether 2-2:1.5 usb1: register ‘cdc_ether’ at usb-0000:00:14.0-2, CDC Ethernet Device, 72:40:f7:72:c9:fa
  2. Next go to Settings->Network and check all the wired connections for the same MAC-address.
  3. In the top right corner there will be an option to enable it.
  4. Next follow the procedure as provided by the SDK manager to install the SDK components

Please see details:
https://devtalk.nvidia.com/default/topic/1048660
https://devtalk.nvidia.com/default/topic/1050668

Hi Carolyuu,

The messages on my host:

  1. cdc_ether 5-2:1.5 usb1: register ‘cdc_ether’ at usb-0000:04:00.0-2, CDC Ethernet Device, 56:3d:4f:be:10:aa

2.3
enable the Mac-address network (see attached.)

still in recovery mode

Hi HuiW,

Looks you still not get host machine ip address.
Can you check all wired status and try again? Also check your micro-usb cable is connected.
If working, your Network will show like:
Hardware Address 86:55:33:47:ED:22
IPv4 Address 192.168.55.100
IPv6 address fe80::1396:58e0:32d4:bf4c

Hi Carolyuu,

Sorry.
Both enp4s0u2 and enp4s0u2i5 did not work.
The other enp3s0 is host original network, and it’s enabled always.

Plus,manaully run below commands did not work either.
sudo ifconfig enp4s0u2i5 192.168.55.100

After run the command, network 192.168.55.100 showed once, but SDK Manage showed “id and pw incorrect”
and stopped. (The thing is id and pw are all correct.)

However, run the command again and again, no network 192.168.55.100 showed again.

Thank you,

Hi HuiW,

Could you please let us know:

  1. What are the ethernet interface port names available on your machine if you run “ip addr”?
  2. What is the error message when running “sudo ifconfig enp4s0u2i5 192.168.55.100”?
  3. Is there something else in the environment preventing to set a static IP address to enp4s0u2i5?

Hi EdwardZhou,

Thank you for your support.
I just realized using another USB port and 192.168.55.100 did auto create successfully.
I will test more to confirm this.
(The thing is I always used the original USB port to install with previous Jetpack.)

I updated the result of your questions, if you still like to know.

  1. What are the ethernet interface port names available on your machine if you run “ip addr”?

4@u1604-pc:~$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether bc:5f:f4:37:5b:08 brd ff:ff:ff:ff:ff:ff
inet 172.16.8.146/24 brd 172.16.8.255 scope global dynamic enp3s0
valid_lft 255756sec preferred_lft 255756sec
inet6 fe80::b956:56c7:9870:5fd0/64 scope link
valid_lft forever preferred_lft forever
7: enp4s0u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
link/ether 42:2f:58:d3:8c:79 brd ff:ff:ff:ff:ff:ff
8: enp4s0u2i5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
link/ether 56:3d:4f:be:10:aa brd ff:ff:ff:ff:ff:ff

  1. What is the error message when running “sudo ifconfig enp4s0u2i5 192.168.55.100”?
    –> no any message

4@u1604-pc:~ sudo ifconfig enp4s0u2i5 192.168.55.100 4@u1604-pc:~

Hi HuiW,

After you using another USB port and can get host IP, can you install SDK components now?

Hi Carolyuu,

Yes. Installed SDK components successfully.

Thank you,