lacp between sx1016 and HP flex 10

I am trying to get LACP to work between HP flex10 module and sx1016 switch (version 3.2.0506). I created a port channel and assigned two ports to it The MTU is 9216 on the sx1016 and 9000 on everything else. The sx1016 thinks the link is up on the port channel and on each interface. The HP flex 10 sees the first port as linked/UnCertified Active in LAG 23 and the second as Linked/UnCertified Standby in LAG 22. I have LLDP enabled on the switch. I believe that UnCertified means that HP has not tested a Mellanox switch. I also have an HP switch and all ports show up as Active and in the same LAG. What do I need to do with the Mellanox to get the ports to all be active?

Dear Lawrence,

To configure LACP:

Step 1.

Log in as admin.

Step 2.

Enter config mode. Run:

switch > enable

switch # configure terminal

Step 3.

Create a port-channel entity. Run:

switch (config) # interface port-channel 1

switch (config interface port-channel 1) #

Step 4.

Change back to config mode. Run:

switch (config interface port-channel 1) # exit

switch (config) #

Step 5.

Enable LACP in the switch. Run:

switch (config) # lacp

switch (config) #

Step 6.

Add a physical port to the port-channel. Run:

switch (config interface ethernet 1/4) # channel-group 1 mode active/passive

switch (config interface ethernet 1/4) #


First off welcome to the community. Let me connect with our support team and see what I can find out for you.


I did all of these things. I also enabled LLDP

Here are the relevant lines from the configuration:

interface ethernet 1/33 mtu 9216

interface ethernet 1/33 speed 10000 force

interface ethernet 1/34 mtu 9216

interface ethernet 1/34 speed 10000 force

interface port-channel 1 mtu 9216

interface ethernet 1/33 channel-group 1 mode on

interface ethernet 1/34 channel-group 1 mode on



sho lacp interfaces ethernet 1/33

Port : 1/33

you should configure mode active or passive on both ethernet interfaces:

  1. First remove the ports from the port-channel, in order to change their mode

no interface ethernet 1/33 channel-group

no interface ethernet 1/34 channel-group

  1. Add the port mode and add them to the port-channel

interface ethernet 1/33 channel-group 1 mode active

interface ethernet 1/34 channel-group 1 mode active


interface ethernet 1/33 channel-group 1 mode passive

interface ethernet 1/34 channel-group 1 mode passive

Please note that if you configure the ports to passive mode, the other side will have to be configured as mode active, as in LACP, 1 side has to be configured as active.


Thanks! That fixed it. The strange thing is that I thought that I had

configured them both as active. I did upgrade the firmware from 0100 t0

0506, because LLDP was not in 0100, but I would not think that would

have changed the LACP configuration. Perhaps I mis-remembered…

Anyway, I really appreciate your help!


Hi Lawrence,

We are happy to help and support,

You can use the following commands to check lag/lacp status:

switch #show interfaces port-channel summary

switch (config interface 1/x)# show interfaces port-channel summary

switch (config) # show lacp interfaces ethernet 1/x