linux driver issue, glx not found when using /etc/X11/xorg.conf configuration file

Hey guys.

i need to enable the tripleframebuffer of the nvidia driver for my geforce780, however when i create xorg.conf by using nvidia-xconfig and rebooting, emerald (and other packages) reports that glx could not be found. - and everything is stuttery and tearing.

if however i run my card without using xorg.conf everything is fine, though i cannot enable the tripleframebuffer.

ive tried using nvidia-xconfig AND merging it with nvidia-settings with the correct options > xorg.conf

This strikes me as particularly weird because in my previous installation of Fedora23 the xorg.conf worked fine, ive even tried using the xorg.conf from that install, which has the same hardware, driver etc.

uname -a

4.2.8-300.fc23.x86_64 #1 SMP Tue Dec 15 16:49:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

lspci | grep NVIDIA

01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)

NVIDIA Driver version 358.16