Fresh Fedora 25 Install, whoops error, X Server 1.19, GeForce GTX 960

I started with a fresh install of Fedora 25 from:
Fedora-Workstation-Live-x86_64-25-1.3.iso (booted from USB stick)

I then performed the 1st update
dnf update

Then I added the RPMFusion repositories (both Free and non-Free) and followed the instructions found at

Then I followed the instructions to install
Current GeForce/Quadro/Tesla
dnf install xorg-x11-drv-nvidia akmod-nvidia “kernel-devel-uname-r == $(uname -r)”
dnf update

Upon reboot I received an error that xorg-x11-server-devel was missing.

I installed xorg-x11-server-devel.

I experiemented with reboots, reinstall on the above packages, and nvidia-xconfig and nothing worked so I decided to start from scratch.

After reformatting, installing, and dnf update, I then manually used
dnf install xorg-x11-server-devel

Then I added the RPMFusion repos and installed following the instructions (including the dnf update).

After rebooting I would start nvidia-settings and get:
You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

root~]# nvidia-xconfig 

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'

I was told some modules were missing and given a command to use the updates-testing repo:
dnf --enablerepo=rpmfusion-nonfree-updates-testing --enablerepo=updates-testing update akmods *\nvidia*

I still run into the same problem. I am attaching a nvidia-bug-report. In generating this report I first manually started X using
startx – -logverbose 6

Any help greatly appreciated!
nvidia-bug-report.log.gz (55.7 KB)

I just found the paper clip and it says it’s adding my nvidia-bug-report.

I noticed there was a kernel update. I reformatted my HD and re-installed Fedora 25 from my USB stick (which I verified).

I updated (dnf update) then added the RPMfusion repos and installed the
Current GeForce/Quadro/Tesla
dnf install xorg-x11-drv-nvidia akmod-nvidia “kernel-devel-uname-r == $(uname -r)”
dnf update

It rebooted to a whoops screen.

I’m attaching the latest nvidia bug report (after startx – -logverbose 6)

nvidia-bug-report.log.gz (56.1 KB)

Disable secure boot or self sign the nvidia module

[    0.000000] Secure boot enabled and kernel locked down

That fixed it. I have marked the answer accepted.

Thank you very much!