Linux USB-C to HDMI adapter stopped working

Current System Info:
OS: Linux Mint 21 x86_64
Host: Dell G15 5520
Kernel: 5.15.0-53-generic
DE: Cinnamon 5.4.12
CPU: 12th Gen Intel i5-12500H (16) @ 4.500GHz
GPU: NVIDIA GeForce RTX 3050 Mobile
GPU: Intel Alder Lake-P
Memory: 1921MiB / 7633MiB

My USB-C adapter no longer works with the new Linux Kernel/ New Linux NVIDIA drives.

When I was using the following and I was able to connect a monitor to the USB-C port via HDMI adapter on the back of my laptop as well as the HDMI port next to it:
Kernel: 5.15.0-48
Driver: nvidia-driver-470 (470.141.03-0ubuntu0.22.04.1)

It stopped working when I tried it on the following Kernels and drivers. In fact, the monitor isn’t even detecting the cable/adapter:
Kernels: 5.15.0-50, 5.15.0-52, & 5.15.0-53 (current)
Drivers: 510.85.02-0ubuntu0.22.04.2, 515.76+really.515.65.0102-0ubuntu0.22.04.2, 520.56.06-0ubuntu0.22.04.1 (current)

Ruled out:

  1. The monitor works with the HDMI port
  2. I tried two adapters that work with two other computers

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thanks for taking a look.

Attached is nvidia-bug-report.log.gz

nvidia-bug-report.log.gz (1.7 MB)

Please remove nomodeset kernel parameter. Your external outputs are driven by the intel igpu.

I put that there to fix an issue similar to this issue (see my comment here).

However, per your suggestion, I removed it. While I don’t have my Dongle and extra monitory with me at the moment, the issue I cited above didn’t reappear when I removed nomodeset. As soon as I get home (tomorrow), I can test the USB-C to HDMI monitor.

Thanks again for taking a look and for the advice.

I removed nomodeset and my system still does not detect the UCB-C monitor. There are some bios settings that didn’t work before. Let me try those again, now that the “nomodeset” has been removed.

Please create a new nvidia-bug-report.log.

You bet. Attached is another nvidia-bug-report.log.gz:

nvidia-bug-report.log.gz (1.6 MB)

I had another issue with graphics where I was unable to dim my monitor’s back light (currently resolved) and another issue with the HDMI surround-sound features (Also currently resolved). I’m wondering if I did something there when fixing those that may have created this issue - like deleting something important, or changing some configuration somewhere. I’ve combed my command history and the files I’ve edited around that time. I haven’t found any evidence of doing any of these things, but could be missing something. So, keep that in mind as to take a look, thanks.

You still have nomodeset in kernel cmdline.

Yup, I did. I made the change to /etc/defaults/grub, but hadn’t issued update-grub

Now that I’ve issued update-grub, the issue is resolved. Thanks!!