USB-C to HDM Adapters Stopped Working After Linux Kernel Update

Computer Stats

[me@myComp /some/dir]$ neofetch
OS: Linux Mint 21 x86_64 
Host: Dell G15 5520 
Kernel: 5.15.0-52-generic 
Uptime: 29 mins 
Packages: 2668 (dpkg), 24 (flatpak) 
Shell: zsh 5.8.1 
Resolution: 1920x1080, 1920x1080 
DE: Cinnamon 5.4.12 
WM: Mutter 
WM Theme: Mint-Y 
Theme: Mint-Y [GTK2/3] 
Icons: Mint-Y [GTK2/3] 
Terminal: terminator 
CPU: 12th Gen Intel i5-12500H (16) @ 4.500GHz
GPU: NVIDIA GeForce RTX 3050 Mobile 
GPU: Intel Alder Lake-P 
Memory: 1995MiB / 7633MiB 

Other Output

[root@myComp /some/dir]# dkms status
nvidia/520.56.06, 5.15.0-52-generic, x86_64: installed

The Issue

After a great deal of trouble, I was able to get my graphics card to work on the latest Kernel for Linux Mint (5.15.0-52-generic as of today). See my post on this forum here for more details on my solution.

Anyway, even though I was able to get the graphics card to work with my new Kernel, I lost the ability to have a monitor attached with a USB-C to HDMI adapter (two known-good adapters tried) which worked before. Now, my system doesn’t even detect any monitor attached to that port.

I’ve gone over my history to see if I made a change that could have caused this while trying to fix the issue stated above but can’t seem to find anything amiss. I just don’t understand why the monitor isn’t even detected anymore.

I’m hoping someone can help investigate why the USB-C to HDMI adapter worked at one time then stopped. I’m at a glorious loss and will provide anyone smarter than me on this topic with any of the necessary logs, command outputs, and praise needed to get this figured out. Thanks