Local Cost Map is not displayed on RViz in Navigation2 Tutorial in Isaac ROS Mission Client library

I am trying to do a tutorial on Isaac ROS Mission Client.
When I set the “launch_rviz” parameter in isaac_ros_vda5050_nav2_client to True, Rviz is displayed, but the cost map is not displayed as shown in the following image.
The same result is obtained by changing the start position.
However, I can run the motion task from the Mission Dispatcher.

The Navigation2 issue answered that the Humble version shows the cost map when using CycloneDDS.

I get an error when I try to build CycloneDDS using the following method in Docker.

--- stderr: cyclonedds                                                                                                                                      
... /... /... /bin/idlc: symbol lookup error: ... /... /... /bin/idlc: undefined symbol: DDS_XTypes_TypeObject_cdrstream_desc
make[2]: *** [src/tools/ddsperf/CMakeFiles/ddsperf_types_generate.dir/build.make:75: src/tools/ddsperf/ddsperf_types.c] Error 127
make[1]: *** [CMakeFiles/Makefile2:505: src/tools/ddsperf/CMakeFiles/ddsperf_types_generate.dir/all] Error 2
make: *** [Makefile:156: all] Error 2
---Error 2
Failed <<< cyclonedds [10.3s, exited with code 2]

There was a bug in FastRTPS that ultimately led to Nav2 not building a local cost map at all as you found. This issue has been resolved (tested locally here as well) with newer version of FastRTPS as indicated here. Are you using Isaac ROS Dev base container or your own installation of ROS 2 on which platform?

Isaac ROS has not been tested on CycloneDDS and when we have tried it, we ran into issues like you ran into.

I am running isaac_ros_dev-x86_64:latest from isaac_ros_common.

People are able to make the isaac_ros/humble/nav2 container work with real robot but for some reason not able to work with isaac sim 2022.2.0 or earlier. Tried all the suggestions found on the internet but not able to reach success hundred percent of the time.

We’re rebuilding the pre-built Isaac ROS Dev base images to pick up the latest rmw_fastrtps package in ROS 2 Humble and will publish the refresh shortly. In the meantime, you can delete the file isaac_ros_common/docker/Dockerfile.<platform>.humble.nav2 to force run_dev.sh to not use the prebuilt images and rebuild locally. Note: This will take a significant amount of time (on the order ofhours).

1 Like

I tried to run run_dev.sh after deleting the Dockerfile as you proposed. I now encounter the following build error:

Can you make a comment on what’s going on

We’ve run into the same issue when we kicked off our own local rebuilds. It looks like a compile error has recently crept into Nav2 packages as what looks like a missing dependency. We’re debugging locally now too, will post updates here. This is why we try to provide pre-built images in the first place as it is not always straightforward.

1 Like

Thanks for keeping us updated. I would also prefer to have a prebuilt version if we are not forced to build it from the source. Do you have a rough estimate when the issue will be fixed an navigation using obstacle and voxel layer is possible?

1 Like

Our newest Isaac ROS Dev base image has the latest FastRTPS version to fix the original problem, and anchors to a specific commit of Nav2 before that compilation error was introduced. You can now use the prebuilt image and Nav2 should work again.