MCP251X connection/setup

I recently started trying to setup a Jetson 2GB Jetson Nano Developer Kit, and trying to communicate it with a MCP251x module. So far I’ve tried different guides from both in this and outside this forum.

Following the steps in this guide, I don’t get any errors, the main problem I do get is that when I try to configure the 40 pin headers for compatible Hardware, the MCP251x is not there, even if my dtbo is in /boot/.

As for the other guide I have 2 main problems/questions.
When you get to step 3 and you have to paste the dts file to
I found out that the folder doesn’t exist in the kernel_src.tbz2 file, rather, to get to the kernel-dts/overlays you have to go to this address instead /hardware/nvidia/platform/tegra/common/kernel-dts/overlays
Is there a problem if the address is not the same? Given that they should be since they were both downloaded from the same site.

Secondly, whenever I get to step 4 Build Device Tree overlay, and I have to use the “make ARCH=arm64 dtbs” command, I get this error:

ERROR (duplicate_label): Duplicate label ‘jetson_io_pinmux’ on /fragment@3/overlay/header-40pin-pinmux and /fragment@2/overlay/exp-header-pinmux
ERROR: Input tree has errors, aborting (use -f to force output)
arch/arm64/boot/dts/Makefile:133: recipe for target ‘arch/arm64/boot/dts/ddot/ddot/ddot/ddot/ddot/ddot/hardware/nvidia/platform/t210/porg/kernel-dts/tegra210-p3448-0000-p3449-0000-a01-mcp251x.dtbo’ failed
make[1]: *** [arch/arm64/boot/dts/ddot/ddot/ddot/ddot/ddot/ddot/hardware/nvidia/platform/t210/porg/kernel-dts/tegra210-p3448-0000-p3449-0000-a01-mcp251x.dtbo] Error 2
arch/arm64/Makefile:154: recipe for target ‘dtbs’ failed
make: *** [dtbs] Error 2

Are there any ideas as to how I can get to setup the 40 pin header for the Jetson? aswell as any tips that might be useful as I work through CAN communication?

P.S. The only other thing I’ve done was remove the following 2 overlays from the /boot/ file, as they’re known to cause issues when running the jetsion-io

hello Skairry,

may I know which JetPack release you’re using?
you should see dts file for MCP251x CAN Controller, please do update the Jetson Device-tree overlay here.
i.e. $public_sources/Linux_for_Tegra/source/public/hardware/nvidia/platform/tegra/common/kernel-dts/overlays/jetson-mcp251x.dts

I’m using the 4.6.1-b110 Jetpack Version.
As for the updated overlay address, I’m working on the address you gave, but I still get the duplicate label error

hello Skairry,

please check your steps, you should confirm you’re using clean kernel sources.
please also refer to Building the NVIDIA Kernel for the steps to build the NVIDIA kernel.

Hi, I’m getting the same ‘duplicate label’ error. Have you managed to figure it out yet? Thanks.

Tested with:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.