Measuring Jetson TK1 board Power

I am trying to measure the Board Power by checking the Voltage drop across R5C11. Is there any other testpoint on the board to check the drop to measure the board power.

Thanks

I haven’t tried to measure the power consumption using the R5C11 but you definitely should see variation there.

I’m using an external power supply that shows both the voltage and the current consumption of the whole board. I’m seeing a jump from 1A to 2A when e.g. compiling something on Jetson using all 4 CPU cores (I do have some motors there as well, but they are idle in this case).

R5C11 sense resistor is 0.005 ohm and the voltage drop would be under 5mV when JTK1 power consumption is under 1A(@12V).
It would be difficult to measure with oscilloscope or voltage meter w/o DAQ or other power measurement equipment.
There is no other sense resistor on JTK1 board, so it’s better to use power supply current numbers to measure the power if you do not have DAQ or other power measure equipment.

With a decent DMM, (not one of those 20$ craftsman ones) you could monitor current out of the DC adapter (barrel plug).

If i can find this R5C11 resistor, ill try it with my meter and see (mine goes down to 50 mV range)
Found it. For anyone else looking for it… its near the barrel connector.
(circled here) http://i.imgur.com/XxNhBPT.png

Idling with Kodi open, voltage measured 2.5-3.25 mV. Probably could relate this back too ampere draw and in turn power, but im not an electrical engineer.
Its probably just V/R = I, right? in that case, ~.6 amps, and in turn 7.2 W.

Out of topic:

As private messages don’t seem to work for me:
Where did you find this nice layout picture? ( https://i.imgur.com/XxNhBPT.png )
Would be cool to have it without your markings.

The layout picture link

Main site for embedded:

https://developer.nvidia.com/embedded-computing

The hardware docs are under “Hardware Design and Development”. New docs / information seem to be emerging every now and then.

I have an oscillioscope(picoscope) which has a DAQ. But the weird part is when I measure the drop at idle I get a value which is very high around .08 mV and when I run an application on the terminal it measures a zero drop. I am unsure why this is happening. Does anyone have any idea?

.08 mV? so thats .00008 V (this isnt high). If i mathed correctly, and it is behaving like i believe it does, thats .00008 V/.005 ohms = .016 A.

I tried to check out the data sheets for the picoscopes (but so many different series), the 2000 series (cheapest one) said it had an accuracy of 3% of its range, So on the 50 mV range, that is 1.5 mV, while you seem to be measuring almost 1/20th of that (.08 mV/1.5 mV). I would really just check that you have the right scale or… setup for measuring the voltage across the resistor, as your numbers seem very far off.

Lets say your DAQ is actually measuring .08 V (80 mV), repeating the process to find the current draw, thats .08 V/.005 ohms = 16 A, which translates to 192 W (one for each CUDA core!). Which again, seems very unlikely.