Minecraft (modded, with shaders) segfaults in libnvidia-glcore.so.331.67 on the nvidia 650 ti boost

When I try loading up a world on a modpack for Minecraft (yogscraft complete, in atlauncher) with shaders (mod: http://www.minecraftforum.net/topic/1544257-172174175shaders-mod-v2312-updated-by-karyonix/ shaderpack: http://www.minecraftforum.net/topic/940974-175sonic-ethers-unbelievable-shaders-v101/ using SEUS v10.0 Standard.zip), I get a segfault in java and it just closes. I’m just going to try to be as detailed as possible here… if you need anymore info I’ll give when needed

Segfault message from console

[2014-05-03 21:21:38] # A fatal error has been detected by the Java Runtime Environment: 
[2014-05-03 21:21:38] # 
[2014-05-03 21:21:38] # SIGSEGV (0xb) at pc=0x00007f5d8e266694, pid=9567, tid=140041792575232 
[2014-05-03 21:21:38] # 
[2014-05-03 21:21:38] # JRE version: Java(TM) SE Runtime Environment (7.0_40-b43) (build 1.7.0_40-b43) 
[2014-05-03 21:21:38] # Java VM: Java HotSpot(TM) 64-Bit Server VM (24.0-b56 mixed mode linux-amd64 compressed oops) 
[2014-05-03 21:21:38] # Problematic frame: 
[2014-05-03 21:21:38] # C [libnvidia-glcore.so.331.67+0xa76694] feof+0xa76694 
[2014-05-03 21:21:38] # 
[2014-05-03 21:21:38] # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again 
[2014-05-03 21:21:38] # 
[2014-05-03 21:21:38] # An error report file with more information is saved as: 
[2014-05-03 21:21:38] # /home/mitchell/atlauncher/Instances/YogscastCompletePack/hs_err_pid9567.log 
[2014-05-03 21:21:38] # 
[2014-05-03 21:21:38] # If you would like to submit a bug report, please visit: 
[2014-05-03 21:21:38] # http://bugreport.sun.com/bugreport/crash.jsp 
[2014-05-03 21:21:38] # The crash happened outside the Java Virtual Machine in native code. 
[2014-05-03 21:21:38] # See problematic frame for where to report the bug. 
[2014-05-03 21:21:38] #

Screenshot of the config I’m using in options --> shaders: http://i.imgur.com/zeI9lmo.png
Screenshot of video settings: http://i.imgur.com/wLh9u91.png
Bug report log.gz: http://wolfmitchell.com/nvidia-bug-report.log.gz

ninja edit: This does not happen on vanilla minecraft, when I’m able to later I’ll test it on the same pack without shaders.

visit: www.minecraftapkz.com