MIPI CSI Camera Connection with Auvidea J20 and VC IMX 296

I am trying to implement a VC IMX 296 csi camera on an AGX Xavier running Ubuntu 18.04 Jetpack 4.6.0 with the Auvidea J20 board connection.

After successfully running the quickstart script from the vc_mipi_nvidia github repo I am still unable to read the camera as nothing is showing up at /dev/video*.

I then tried running configuration commands for the J20 as reommended from the RidgeRun Getting started guide:

That turned on the GPIO LED on the J20 board but still no read from the /dev/video* directory.

Running $dmesg | grep ‘i2c’ gives the following output. Leading me to believe it flashed correctly.

And running $sudo i2cdetect -y -r 2 gives:


My camera is connected to the second port (J1_2) on the Auvidea J20 board. Still no prevail on being able to read the camera.

If there are any suggestions on how to move forward please let me know!


The camera is getting the expected power supply after our check. How do we check the MCLK normal and use the i2c-tools command to debug?

Thanks in advance,

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

hello brjthomas,

were those IMX296 camera register to linux kernel correctly?
could you please attach the complete kernel logs for reference, i.e. $ dmesg > klogs.txt