MLAG not forwarding traffic through the slave switch

I have created an MLAG according to the instruction. The status is all in green, Mpo is up, however when I have added a VLAN to Mpo and a port on the slave switch where I have a single homed server connected the packets are not passed. (destination host unreachable).

The same happens with access vlan.

I have even created the VLAN interfaces on the switches and it becomes even more interesting:

Server A - Switch 1 - Switch 2 - server B

server A is connected only to Switch 1

server B to both Switch 1 and Switch 2 via MLAG with LACP Active mode,
LACP shows 2 links active on both server and the switch

lets say I create an VLAN interface on both switches, switch A gets, switch B

I put both servers in the subnet

Now magic happens:

I can ping AND from server A
I can ping ONLY from server B

I cannot ping one server from the other.

When I tear down the Mpo and ping server A from server B through interface connected to switch 1 - ping returns ok, but when I do the same trhough interface conencted to switch 2 - ping bounces (I guess this is normal? the traffic outside Mpo will not traverse IPL?)

When I connect server A to switch 2 I can ping one server from the other over Mpo/LACP on server B, however if I kill the switch 2 interface for serverB leaving only switch 1 connection the traffic stops flowing as it would not cross IPL…

Any way to debug this further? Tried to find a solution for 2 days now and it seems more and more strange.

sw version 3.6.8012 on both switches.

Update, this happens only on bonded interfaces, If I remove bonding - any to any port works. With bonding (LACP with proper switch config it will let “some” traffic - between some host pairs), with Xenserver active-active (slb loadballancing, not requiring any specific switch config) it behaves the same as LACP, will let some source-destination combinations…

The problem is related to openvswitch… reverting to linux bonding solved the issue. Can close the thread :)