My AGX Xavier Bricked and Not Re-flashable


I bought Nvidia’s AGX Xavier about three months ago via Amazon, and flashed it just a week ago. Two days ago, my AGX Xavier was bricked (powered on but nothing showed up on the screen), so I tried to re-flash AGX using sdk manager. However, even though my host PC can detect AGX by “lsusb,” sdk manager keeps failing installation because of errors like below. I tried to re-flash using different versions of jetpack and different host machines, but it could not help me. I wanted to install OS image file to a micro SD card and boot AGX from the micro SD card, but Nvidia doesn’t support it for AGX. I think it looks like hardware issues. What can I do?

Thank you. (315.2 KB)

Hello @jkc7848

please download the latest BSP from here and follow the flashing instructions described here. This will provide a more detailed flashing log and help us understand the issue.

Hi Mike.

I really don’t know why, but I successfully flashed my machine by following the link you gave me. I am so confused right now. Probably there’s something wrong with SDK manager I guess…? Thank you so much by the way :)