My Nano has died... Anything I can do other than simply return it?

Hi everyone. My first post here so please be gentle. :)

I have a Nano that I hadn’t used for a couple of months. I decided to play with it the other night so hooked it up and booted into the Linux desktop. Clicking on icons and things on the desktop didn’t seem to have an effect (how odd!) and since I saw there was a newer microSD image available for download I went and grabbed that and put it on a microSD card. OK, so I booted the new image and went through the process of installing/configuring. At one point I had a window “applying changes” where it sat for ages “waiting for unattended-upgr to exit”. It took so long I went away and came back the next day. The next day when I returned it was displaying a text screen - the type you get when booting Linux. There were some kernel messages up to 3.68 seconds after boot, then after that messages along the lines of “started resolvconf-pull-resolved.service.” (repeats a few times), then one failed one: “failed to start nv-oem-config-gui.service”. I power cycled the Nano, but then I didn’t get any video output despite trying a number of times. I tried another microSD card with image but still no video. I read on the forum about the serial console so tried connecting to that, but nothing visible. Hmm. So I went and bought another Nano…

The second Nano arrived and I created a new microSD image and the new Nano booted fine. I tried connecting the serial cable to the new Nano and that worked, producing serial output about a second after boot, right up to the point where I could log in on the serial console. Also video output with Linux destop. Yay! So all good with the new Nano. I then swapped the new Nano out for the old Nano. With the old Nano, no video output. No serial output. The green LED does come on when I apply power but that’s the only sign of life I can see.

Is there something more I can do to diagnose further, or is it best to return it as faulty? Unfortunately shipping will be international and hence expensive, though probably still worth doing. Maybe.

I can hardly remember the last time I had a piece of hardware fail like this.

-Martin

Hi Martin,

For your first nano, could you also try to use sdkmanager to flash your sdcard and see if it can boot up?

Hi Wayne. I’m not familiar with sdkmanager. I’ll have a look at flashing a microSD card with it, though I’m not sure that will help. The reason is that on the new working Nano it looks like I get serial console output earlier on in the boot stage, even before the stage where the microSD card is accessed. On the old, suspected faulty Nano I don’t see any serial output at all. Still, I’ll try this alternative way of creating the microSD (I have been using dd till now)… Thanks for the reply.

Also, if sdkmanager does not help, please file RMA for your old nano.

Hi Wayne,

I think the sdkmanager approach is working! After considerable https://en.wiktionary.org/wiki/yak_shaving I succeeded in setting up a working sdkmanager. I followed the instructions for a manual install onto the Nano and I’m only part way through at the moment but the Nano rebooted at one point and Ubuntu successfully booted complete with HDMI output. So I think the hardware is OK! Thank you!!! This now suggests to me that something software related happened while running the latest image (r32.2-2019-07-16) that caused it to brick itself. Seems like a long shot, but I cannot explain it otherwise.

It will be interesting to see what happens once sdkmanager has finished, I reboot and perform a package update. Will it brick itself again? Or has sdkmanager updated my firmware and it will be fine? The problematic Nano was one of the early boards so maybe it had early firmware. Anyway, lots of speculation and lots of maybes! For now I’m happy it lives again!!! Thanks again!

-Martin

Hi Martin,

Actually, sdkmanager provides almost the same content as the sdcard image. However, we notice some issues have been reported by users and only for sdcard case.

Our team is still trying to improve it. Glad that it is working.

My (old, first) Nano has been busy for the last few days compiling things, but today I checked and it has all the latest packages installed, and it’s still behaving. No more boot problems. Great! Thank you again!

The funny thing is, if I try and boot it with a microSD card that I created prior to using sdkmanager it will now boot. I have a few microSD cards with different images lying around. At least I’m 95% sure I created the card in question back when the Nano wouldn’t boot. Now it boots. Hmm! My conclusion is that sdkmanager did something not just to the microSD card inserted at the time the Nano was being recovered, but also did something to the Nano itself. Still, I’m just a newbie when it comes to the Nano so I may be off base.

Regards,

-Martin (now with two working Nanos, woohoo! :-))