Nano cannot mount PCIe SSD as roofts

Hello, everyone.
I used a PCIe SSD as roofts so I can get more disk space. And the performance is probably as below:

  1. About 30% probability, login EMMC successfully, and SSD was auto found and mount. This proves the PCIe driver and SSD device works.
  2. About 20% probability, boot failed and stuck in the ‘NVIDIA’ white logo.
  3. 40% probability, report PCIe error as below when booting:
  4. very rarely, I can mount SSD as rootfs successfully, after many error reports as 3.

The 4 situation above, can be reached by hot or cold reboot.

My hardware: I used jetson NX before, and remain the same Interface design for nano. And NX can works normally in my board while Nano can’t.

Firmware: nano SDK version is 32.5.1, NX version is 32.4.3, are both default firmware.

So, what’s the problem might be? I think NX and Nano, they have the same hardware interfaces.

Everything can be supplied, circuit diagram, logs etc. Debug serrial port didn’t layout.

Need the debug serial output log.

Hello WayneWWW, thank you for your help.
Corresponding to different phenomena, 3 debug serrial logs are supplied as below:

  1. login EMMC
    emmc.txt (181.1 KB)
  2. boot failed and stuck
    stuck.txt (382.0 KB)
  3. successfully boot from SSD as rootfs
    success.txt (484.5 KB)

I can’t get more useful message except PCIe error. But sometimes it can boot successfully with these errors, I don’t understand why.

Do you have other kind of SSD that can test?

Hello WayneWWW.
So far, I’ve tried 2 kinds of SSD, and they got the same phenomena.
Why NX can work normally in my board while Nano have this problem, is there any difference between NX and Nano in PCIe?

They use totally different PCIe controller.

Try to enable/disable aspm on your jetson nano and try again.

The 4 situation above is with ASPM enable by default.
I’ve tried to disable ASPM driver by recompiling kernel, and input “lspci -vvvv”, it shows ASPM is disabled, but the problem is still remain.

Hello, WayneWWW.
Sorry for troubling, but I just have no idea for this problem. Our hardware engineers also don’t know how to solve it in next board while NX runs well on it.
Need your assistance, some keywords or directions plz.

Do not mount them as rootfs disk. Just boot it up and try to reproduce error.

When error happened, share the result of lspci -vvv and full dmesg.

Just some thoughts on this…

It might be the PCIe component and not the actual SSD. Probably it is from those errors. Is this a separate PCIe carrier board, or is the SSD integrated to the PCIe? It would be interesting to place the PCIe into a desktop Ubuntu system and run “sudo lspci -vvv” on it when it is working (you can limit the lspci to a specific slot to get a smaller log rather than running verbose lspci on every PCI device).

As an example for logging, if you plug this into a desktop PC with Ubuntu, and run lspci (no arguments), and find the slot to be “00:01.1” (that’s just a contrived example), then you could do this to get a fully verbose log of just that device:
sudo lspci -vvv -s 00:01.1 2>&1 | tee log_pc_verbose_lspci.txt

The SSD itself will have nothing to do with the problem until PCIe is working.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.