Jetson Nano unable to boot SSD as system disk

Mount the SSD as a system disk, and the mount is successful after rebooting. But after unplugging the power and turning it on again, it shows that the SSD is not installed. Then, without any modification, after entering reboot in the terminal, it shows that it has been successfully mounted as a system disk. This problem does not occur on Jetson NX.
Jetson Nano can be successfully mounted on hot boot, but it cannot be mounted after power off.
What is the problem?

Are we talking about mounting ssd as system disk or it is just want to mount it as data disk after boot?

mounting ssd as system disk

It is possible to mount as a data disk after booting

Then you better sharing the uart log when the error happened.

[16:10:40.746]收←◆\0
[16:10:41.020]收←◆[0000.271] [L
[16:10:41.146]收←◆4T TegraBoot] (version 00.00.2018.01-l4t-8728f3cb)
[0000.276] Processing in cold boot mode Bootloader 2
[0000.281] A02 Bootrom Patch rev = 1023
[0000.284] Power-up reason: pmc por
[0000.287] No Battery Present
[0000.290] pmic max77620 reset reason
[0000.293] pmic max77620 NVERC : 0x40
[0000.297] RamCode = 0
[0000.299] Platform has DDR4 type RAM
[0000.303] max77620 disabling SD1 Remote Sense
[0000.307] Setting DDR voltage to 1125mv
[0000.311] Serial Number of Pmic Max77663: 0x321761
[0000.318] Entering ramdump check
[0000.321] Get RamDumpCarveOut = 0x0
[0000.325] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.330] Last reboot was clean, booting normally!
[0000.334] Sdram initialization is successful
[0000.338] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.345] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.350] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.356] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.362] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.368] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.374] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.380] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.396] RamDump Carveout Ba
[16:10:41.186]收←◆se=0x00000000ff280000 Size=0x00080000
[0000.402] Platform-DebugCarveout: 0
[0000.405] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.411] Non secure mode, and RB not enabled.
[0000.415] *** Booting BFS0.
[0000.418] Initialize FailControl
[0000.421] Read PT from (0:3)
[0000.436] Csd NumOfBlocks=0

[16:10:41.356]收←◆[0000.475] PT crc32 and magic check passed.
[0000.479] Using BFS PT to query partitions
[0000.483] PT: Partition LNX NOT found !
[0000.487] *** Booting KFS0.
[0000.489] NvTbootFailControlDoFailover: No failover; Continuing …
[0000.495] BoardID = 3448, SKU = 0x2
[0000.499] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0000.504] Read GPT from (0:3)
[0000.512] Using GPT Primary to query partitions
[0000.517] NvTbootFailControlDoFailover: No failover; Continuing …
[0000.524] Loading Tboot-CPU binary
[0000.529] Verifying TBC in OdmNonSecureSBK mode
[0000.539] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.546] Bootloader downloaded successfully.
[0000.550] Downloaded Tboot-CPU binary to 0xa0000258
[0000.555] MAX77620_GPIO5 configured
[0000.559] CPU power rail is up
[0000.562] CPU clock enabled
[0000.565] Performing RAM repair
[0000.568] Updating A64 Warmreset Address to 0xa00002e9
[0000.573] BoardID = 3448, SKU = 0x2
[0000.577] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0000.583] NvTbootFailControlDoFailover: No failover; Continuing …
[0000.589] Loading NvTbootBootloaderDTB

[16:10:41.386]收←◆[0000.606] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode

[16:10:41.466]收←◆[0000.677] Bootloader DTB Load Address: 0x83000000
[0000.682] BoardID = 3448, SKU = 0x2
[0000.685] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0000.691] Loading NvTbootKernelDTB
[0000.708] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode

[16:10:41.576]收←◆[0000.779] Kernel DTB Load Address: 0x83100000
[0000.783] BoardID = 3448, SKU = 0x2
[0000.786] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0000.792] NvTbootFailControlDoFailover: No failover; Continuing …
[0000.799] Loading cboot binary
[0000.811] Verifying EBT in OdmNonSecureSBK mode

[16:10:41.696]收←◆[0000.852] Bootloader load address is 0x92c00000, entry address is 0x92c00258
[0000.859] Bootloader downloaded successfully.
[0000.864] BoardID = 3448, SKU = 0x2
[0000.867] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0000.873] NvTbootFailControlDoFailover: No failover; Continuing …
[0000.879] PT: Partition NCT NOT found !
[0000.883] Warning: Find Partition via PT Failed
[0000.887] Next binary entry address: 0x92c00258
[0000.892] BoardId: 3448
[0000.896] Overriding pmu board id with proc board id
[0000.901] Display board id is not available
[0000.905] BoardID = 3448, SKU = 0x2
[0000.908] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0000.914] NvTbootFailControlDoFailover: No failover; Continuing …
[0000.928] Verifying SC7EntryFw in OdmNonSecureSBK mode

[16:10:41.766]收←◆[0000.984] /bpmp deleted
[0000.986] SC7EntryFw header found loaded at 0xff700000

[16:10:41.946]收←◆[0001.174] OVR2 PMIC

[16:10:42.039]收←◆[0001.176] Bpmp FW successfully loaded
[0001.179] BoardID = 3448, SKU = 0x2
[0001.183] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0001.189] NvTbootFailControlDoFailover: No failover; Continuing …
[0001.196] WB0 init successfully at 0xff780000
[0001.200] Verifying NvTbootWb0 in OdmNonSecureSBK mode
[0001.205] Set NvDecSticky Bits
[0001.209] GSC2 address ff53fffc value c0edbbcc
[0001.215] GSC MC Settings done
[0001.218] BoardID = 3448, SKU = 0x2
[0001.221] Not Nano-SD or !QSPI-ONLY, check GPT table first …
[0001.228] TOS Image length 53680
[0001.231] Monitor size 53680
[0001.234] OS size 0
[0001.239] Secure Os AES-CMAC Verification Success!
[0001.244] TOS image cipher info: plaintext
[0001.248] Loading and Validation of Secure OS Successful
[00
[16:10:42.120]收←◆01.263] SC7 Entry Firmware - 0xff700000, 0x4000
[0001.268] NvTbootPackSdramParams: start.
[0001.273] NvTbootPackSdramParams: done.
[0001.277] Tegraboot started after 201366 us
[0001.281] Basic modules init took 741846 us
[0001.285] Sec Bootdevice Read Time = 54 ms, Read Size = 3682 KB
[0001.291] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0001.296] Next stage binary read took 7388 us
[0001.300] Carveout took -34781 us
[0001.303] CPU initialization took 392185 us
[0001.307] Total time taken by TegraBoot 1106638 us

[0001.312] Starting CPU & Halting co-processor

64NOTICE: BL31: v1.3(release):b5eeb33
NOTICE: BL31: Built : 08:56:32, Feb 19 2022
ERROR: Error initializing runtime service trusty_fast

[16:10:42.220]收←◆[0001.434] RamCode = 0
[0001.4
[16:10:42.380]收←◆39] LPDDR4 Training: Read DT: Number of tables = 2
[0001.444] EMC Training (SRC-freq: 204000; DST-freq: 1600000)
[0001.457] EMC Training Successful
[0001.460] 408000 not found in DVFS table
[0001.466] RamCode = 0
[0001.469] DT Write: emc-table@204000 succeeded
[0001.475] DT Write: emc-table@1600000 succeeded
[0001.479] LPDDR4 Training: Write DT: Number of tables = 2
[0001.524]
[0001.525] Debug Init done
[0001.527] Marked DTB cacheable
[0001.530] Bootloader DTB loaded at 0x83000000
[0001.535] Marked DTB cacheable
[0001.538] Kernel DTB loaded at 0x83100000
[0001.542] DeviceTree Init done
[0001.555] Pinmux applied successfully
[0001.559] gicd_base: 0x50041000
[0001.563] gicc_base: 0x50042000
[0001.566] Interrupts Init done
[0001.570] Using base:0x60005090 & irq:208 for tick-timer
[0001.575] Using base:0x60005098 for delay-timer
[0001.579] platform_init_timer: DONE
[0001.583] Timer(tick) Init done
[0001.587] osc freq = 38400 khz
[0001.590]
[0001.592] Welcome to L4T Cboot
[0001.595]
[0001.596] Cboot Version: 00.00.2018.01-t210-a2f2e4b8
[0001.601] calling constructors
[0001.604] initializing heap
[0001.606] initializing threads
[0001.609] initializing timers
[0001.612] creating bootstrap completion thread
[0001.616] top of bootstrap2()
[0001.619] CPU: ARM Cortex A57
[0001.622] CPU: MIDR: 0x411FD071, MPIDR: 0x80000000
[0001.627] initializing platform

[16:10:42.560]收←◆[0001.681] Config for emmc ddr50 mode completed
[0001.685] sdmmc bdev is already initialized
[0001.689] Enable APE clock
[0001.692] Un-powergate APE partition
[0001.695] of_register: registering tegra_udc to of_hal
[0001.700] of_register: registering inv20628-driver to of_hal
[0001.706] of_register: registering ads1015-driver to of_hal
[0001.711] of_register: registering lp8557-bl-driver to of_hal
[0001.717] of_register: registering bq2419x_charger to of_hal
[0001.723] of_register: registering bq27441_fuel_gauge to of_hal
[0001.734] gpio framework initialized
[0001.738] of_register: registering tca9539_gpio to of_hal
[0001.743] of_register: registering tca9539_gpio to of_hal
[0001.748] of_register: registering i2c_bus_driver to of_hal
[0001.754] of_register: registering i2c_bus_driver to of_hal
[0001.760] of_register: registering i2c_bus_driver to of_hal
[0001.765] pmic framework initialized
[0001.769] of_register: registering max77620_pmic to of_hal
[0001.774] regulator framework initialized
[0001.778] of_register: registering tps65132_bl_driver to of_hal
[0001.784] initializing target
[0001.790] gpio_driver_register: register ‘tegra_gpio_driver’ driver
[0001.798] board ID = D78, board SKU = 2
[0001.804] fixed regulator driver initialized

[16:10:42.756]收←◆[0001.822] initializing OF layer
[0001.825] NCK carveout not present
[0001.828] Skipping dts_overrides
[0001.832] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.849] I2C Bus Init done
[0001.852] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.862] I2C Bus Init done
[0001.865] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.875] I2C Bus Init done
[0001.877] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.888] I2C Bus Init done
[0001.890] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.901] I2C Bus Init done
[0001.903] of_children_init: Ops found for compatible string maxim,max77620
[0001.914] max77620_init using irq 118
[0001.919] register ‘maxim,max77620’ pmic
[0001.923] gpio_driver_register: register ‘max77620-gpio’ driver
[0001.929] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.940] I2C Bus Init done
[0001.943] NCK carveout not present
[0001.953] Find /i2c@7000c000’s alias i2c0
[0001.956] get eeprom at 1-a0, size 256, type 0
[0001.965] Find /i2c@7000c500’s alias i2c2
[0001.969] get eeprom at 3-a0, size 256, type 0
[0001.973] get eeprom at 3-ae, size 256, type 0
[0001.978] pm_ids_update: Updating 1,a0, size 256, type 0
[0001.983] I2C slave not started
[0001.986] I2C write failed
[0001.989] Writing offset failed
[0001.992] eeprom_init: EEPROM read failed
[0001.996] pm_ids_update: eeprom init failed
[0002.000] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.030] pm_ids_update: The pm board
[16:10:42.826]收←◆id is 3448-0002-401
[0002.037] Adding plugin-manager/ids/3448-0002-401=/i2c@7000c500:module@0x50
[0002.045] pm_ids_update: pm id update successful
[0002.050] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.055] I2C slave not started
[0002.058] I2C write failed
[0002.061] Writing offset failed
[0002.064] eeprom_init: EEPROM read failed
[0002.068] pm_ids_update: eeprom init failed
[0002.098] eeprom_get_mac: EEPROM invalid
[16:10:42.966]收←◆MAC address (all 0xff)
[0002.103] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0002.111] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0002.117] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0002.126] updating /chosen/nvidia,ethernet-mac node 48:b0:2d:3d:e0:18
[0002.132] Plugin Manager: Parse ODM data 0x000a4000
[0002.144] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000
[0002.159] Find /i2c@7000c000’s alias i2c0
[0002.163] get eeprom at 1-a0, size 256, type 0
[0002.171] Find /i2c@7000c500’s alias i2c2
[0002.175] get eeprom at 3-a0, size 256, type 0
[0002.180] get eeprom at 3-ae, size 256, type 0
[0002.184] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.189] I2C slave not started
[0002.192] I2C write failed
[0002.195] Writing offset failed
[0002.198] eeprom_init: EEPROM read failed
[0002.202] pm_ids_update: eeprom init failed
[0002.206] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.236] pm_ids_update: The pm board id is 3448-0002-401

[16:10:43.032]收←◆[0002.242] Adding plugin-manager/ids/3448-0002-401=/i2c@7000c500:module@0x50
[0002.249] pm_ids_update: pm id update successful
[0002.254] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.259] I2C slave not started
[0002.262] I2C write failed
[0002.265] Writing offset failed
[0002.268] eeprom_init: EEPROM read failed
[0002.272] pm_ids_update: eeprom init failed
[0002.302] Add serial number:1424021061041 as DT property

[16:10:43.072]收←◆[0002.309] Applying platform configs
[0002.316] platform-init is not present. Skipping
[0002.321] calling apps_init()

[16:10:43.122]收←◆[0002.342] Found 17 GPT partitions in “sdmmc3_user”
[0002.346] Proceeding to Cold Boot
[0002.350] starting app android_boot_app
[0002.353] Device state: unlocked
[0002.357] display console init
[0002.365] could not find regulator
[0002.368] hdmi cable connected
[0002.384] edid read success
[0002.399] edid
[16:10:43.288]收←◆read success
[0002.4[0002.405] DT entry for leds-pwm not found
01] width = 640, height = 480, frequency = 25174825
[0002.414] width = 640, height = 480, frequency = 25174825
[0002.419] width = 640, height = 480, frequency = 25174825
[0002.425] width = 1440, height = 900, frequency = 106500000
[0002.430] width = 1280, height = 768, frequency = 79500000
[0002.436] width = 1366, height = 768, frequency = 85500000
[0002.441] width = 1280, height = 720, frequency = 74250000
[0002.447] width = 640, height = 480, frequency = 25174825
[0002.452] width = 720, height = 480, frequency = 26973026
[0002.457] width = 720, height = 480, frequency = 26973026
[0002.463] width = 1280, height = 720, frequency = 74175824
[0002.468] width = 1920, height = 1080, frequency = 148351648
[0002.474] width = 720, height = 576, frequency = 26973026
[0002.479] width = 1280, height = 720, frequency = 74175824
[0002.485] width = 1920, height = 1080, frequency = 148351648
[0002.490] Best mode Width = 1920, Height = 1080, freq = 148351648
[0002.498] tmds-config node not found
[0002.502] pmc_set_io_pad_voltage: Error -2 retrieving platform-io-pad-voltagepropsetting ‘avdd-io-hdmi-dp’ regulator to 1050000 micro volts
[0002.517] setting ‘vdd-1v8’ regulator to 1800000 micro volts
[0002.525] could not find regulator
[0002.528] could not find regulator
[0002.531] could not find regulator
[0002.560] using default cmu settings

[16:10:43.368]收←◆[0002.563] dc_hdmi_enable, starting HDMI initialisation
[0002.569] dc_hdmi_enable, HDMI initialisation complete
[0002.574] list and configure display window
[0002.583] display console init completed
[0002.594] subnode volume_up is not found !
[0002.598] subnode back is not found !
[0002.602] subnode volume_down is not found !
[0002.606] subnode menu is not found !
[0002.609] Gpio keyboard init success

[16:10:43.398]收←◆[000
[16:10:43.428]收←◆2.657] found decompressor handler: lz4-legacy
[0002.671] decompressing blob (type 1)…

[16:10:43.580]收←◆[0002.741] load_bmp_blob: panelresolution=1080 type=3
[0002.746] -------> se_aes_verify_sbk_clear: 747
[0002.750] se_aes_verify_sbk_clear: Error
[0002.754] SE operation failed
[0002.757] bl_battery_charging: connected to external power supply
[0002.772] device_query_partition_size: failed to open partition sdmmc3_user:MSC !
[0002.780] MSC Partition not found
[0002.790] device_query_partition_size: failed to open partition sdmmc3_user:USP !
[0002.797] USP partition read failed!
[0002.800] blob_init: blob-partition USP header read failed
[0002.806] android_boot Unable to update recovery partition
[0002.811] kfs_getpartname: name = LNX
[0002.815] Loading kernel from LNX

[16:10:43.651]收←◆[0002.905] load kernel from storage
[0002.915] decompressor handler not found

[16:10:43.716]收←◆[0002.948] Successfully loaded kernel and ramdisk images
[0002.953] board ID = D78, board SKU = 2
[0002.958] load_bmp_blob: panelresolution=1080 type=3

[16:10:44.192]收←◆[0003.454]
[16:10:44.282]收←◆display bmp image done
[0003.457] NCK carveout not present
[0003.461] Skipping dts_overrides
[0003.464] NCK carveout not present
[0003.473] Find /i2c@7000c000’s alias i2c0
[0003.477] get eeprom at 1-a0, size 256, type 0
[0003.486] Find /i2c@7000c500’s alias i2c2
[0003.490] get eeprom at 3-a0, size 256, type 0
[0003.494] get eeprom at 3-ae, size 256, type 0
[0003.499] pm_ids_update: Updating 1,a0, size 256, type 0
[0003.504] I2C slave not started
[0003.507] I2C write failed
[0003.510] Writing offset failed
[0003.513] eeprom_init: EEPROM read failed
[0003.517] pm_ids_update: eeprom init failed
[0003.521] pm_ids_update: Updating 3,a0, size 256, type 0
[0003.551] pm_ids_update: T
[16:10:44.342]收←◆he pm board id is 3448-0002-401
[0003.558] Adding plugin-manager/ids/3448-0002-401=/i2c@7000c500:module@0x50
[0003.566] pm_ids_update: pm id update successful
[0003.571] pm_ids_update: Updating 3,ae, size 256, type 0
[0003.576] I2C slave not started
[0003.579] I2C write failed
[0003.582] Writing offset failed
[0003.585] eeprom_init: EEPROM read failed
[0003.589] pm_ids_update: eeprom init failed
[0003.618] eeprom_get_mac: EE
[16:10:44.592]收←◆PROM invalid MAC address (all 0xff)
[0003.624] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0003.632] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0003.638] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0003.646] updating /chosen/nvidia,ethernet-mac node 48:b0:2d:3d:e0:18
[0003.653] Plugin Manager: Parse ODM data 0x000a4000
[0003.665] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000
[0003.673] Add serial number:1424021061041 as DT property
[0003.682] “bpmp” doesn’t exist, creating
[0003.688] Updated bpmp info to DTB
[0003.693] Updated initrd info to DTB
[0003.696] “proc-board” doesn’t exist, creating
[0003.702] Updated board info to DTB
[0003.706] “pmu-board” doesn’t exist, creating
[0003.712] Updated board info to DTB
[0003.715] “display-board” doesn’t exist, creating
[0003.721] Updated board info to DTB
[0003.724] “reset” doesn’t exist, creating
[0003.729] Updated reset info to DTB
[0003.732] Cmdline: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1125 core_edp_ma=4000 gpt tegra_fbmem=0x800000@0x92cb4000 is_hdmi_initialised=1
[0003.771] DTB cmdline: earlycon=uart8250,mmio32,0x70006000
[0003.777] boot image cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1 nv-auto-config
[0003.794] Updated bootarg info to DTB
[0003.798] Adding uuid 00000001643174090800000011048100 to DT
[0003.804] Adding eks info 0 to DT
[0003.809] WARNING: Failed to pass NS DRAM ranges to TOS, err: -7
[0003.815] Updated memory info to DTB
[0003.823] set vdd_core voltage to 1125 mv
[0003.827] setting ‘vdd-core’ regulator to 1125000 micro volts
[0003.833] Found secure-pmc; disable BPMP

[16:10:44.992]收←◆

U-Boot 2020.04-g4335beb (Feb 19 2022 - 08:56:35 -0800)

SoC: tegra210
Model: NVIDIA Jetson Nano Developer Kit
Board: NVIDIA P3450-0000
DRAM:
[16:10:45.179]收←◆4 GiB

[16:10:45.299]收←◆MMC: sdhci@700b0000: 1, sdhci@700b0600: 0
Loading Environment from MMC…
[16:10:45.359]收←◆*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Net: No ethernet found.
Hit any key to stop autoboot: 2
[16:10:46.376]收←◆ 1
[16:10:47.385]收←◆ 0
MMC: no card present

[16:10:47.435]收←◆switch to partitions #0, OK
mmc0(part 0) is current device

[16:10:47.684]收←◆Scanning mmc 0:1…

[16:10:47.814]收←◆Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf

[16:10:47.884]收←◆894 bytes read in 31 ms (27.3 KiB/s)
1: primary kernel
Retrieving file: /boot/initrd

[16:10:48.101]收←◆7159624 bytes read in 180 ms (37.9 MiB/s)
Retrieving file: /boot/Image

[16:10:48.893]收←◆34484232 bytes read in 7
[16:10:48.983]收←◆80 ms (42.2 MiB/s)
append: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1125 core_edp_ma=4000 gpt tegra_fbmem=0x800000@0x92cb4000 is_hdmi_initialised=1 earlycon=uart8250,mmio32,0x70006000 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1 nv-auto-config quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1 nv-auto-config

[16:10:49.093]收←◆## Flattened Device Tree blob at 83100000
Booting using the fdt blob at 0x83100000
ERROR: reserving fdt memory region failed (addr=0 size=0)
ERROR: reserving fdt memory region failed (addr=0 size=0)
Using Device Tree in place at 0000000083100000, end 000000008317ce8d
copying carveout for /host1x@50000000/dc@54200000…
copying carveout for /host1x@50000000/dc@54240000…

Starting kernel …

[16:10:49.263]收←◆[ 0.000000] Booting Linux on physical CPU 0x0
[ 0.000000] Linux version 4.9.253-tegra (buildbrain@mobile-u64-5434-d8000) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #1 SMP PREEMPT Sat Feb 19 08:59:22 PST 2022
[ 0.000000] Boot CPU: AArch64 Processor [411fd071]
[ 0.000000] OF: fdt:memory scan node memory@80000000, reg size 32,
[ 0.000000] OF: fdt: - 80000000 , 7ee00000
[ 0.000000] OF: fdt: - 100000000 , 7f200000
[ 0.000000] Found tegra_fbmem: 00800000@92cb4000
[ 0.000000] earlycon: uart8250 at MMIO32 0x0000000070006000 (options ‘’)
[ 0.000000] bootconsole [uart8250] enabled

[16:10:50.829]收←◆[ 1.145340] tegradc tegradc.1: dpd enable lookup fail:-19

[16:10:51.140]收←◆[ 1.326896] imx219 7-0010: imx219_board_setup: error during i2c read probe (-121)
[ 1.326963] imx219 7-0010: board setup failed
[ 1.350895] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[ 1.350962] imx219 8-0010: board setup failed

[16:10:51.545]收←◆[ 1.872321] cgroup: cgroup2: unknown option “nsdelegate”

[16:10:52.946]收←◆[ 3.284682] using random self ethernet address

[16:10:52.976]收←◆[ 3.306151] using random host ethernet address

[16:10:53.556]收←◆[ 3.855839] random: crng init done
[ 3.859271] random: 7 urandom warning(s) missed due to ratelimiting
[ 3.874722] using random self ethernet address
[ 3.881157] using random host ethernet address

[16:10:54.817]收←◆[ 5.153978] Bridge firewalling registered

[16:10:57.714]收←◆
Ubuntu 18.04.6 LTS ubuntu ttyS0

ubuntu login:

Please also share dmesg. As a text file.

Attach it here.

Hi WaynWWW,

I attached log files below for @waylo.

Power off then power on kernel dmesg log:
kernel dmesg log.txt (59.2 KB)

Software reboot kernel dmesg log:
reboot-dmesg-log.txt (60.7 KB)

Software reboot uart print log:
reboot-uart-tool-og.txt (24.2 KB)

Thanks for your support to analyze .

I suppose it wouldn’t be easy to edit the extlinux.conf, but you might want to remove the “quiet” from the APPEND line and get another serial console boot log. Also, is it correct that this is a third party carrier board and not a dev kit? If so, did you use the carrier board’s flash software?

I don’t see any log indicating you are using the SSD as system disk.

Are you sure you really mount the SSD as system disk? What is your method to tell “this is mounted as system disk”?

Also, did you make any configuration in bootloader to make it boot from SSD?