[Need help] Cannot boot or reset Jetson after apt-get upgrade with dpkg force rewrite

Hi. I have an issue with booting my Jetson Xavier NX.
Below is what i did to my Jetson.

  1. Run apt-get update and apt-get upgrade via SSH
  2. reboot
  3. No display output from Jetson, but ssh was available
  4. When i connected to ssh console, it said like “loader failed. lib*** was not found.”
  5. i thought this was caused by my apt-get operation.
  6. i retried apt-get update and apt-get upgrade
  7. apt-get upgrade failed since some libraries required different version of ONE library. And it said cannot overwrite some files.
  8. i ran
apt-get -o Dpkg::Options::="--force-overwrite" --fix-broken install

. (I’m not sure exact command i ran in this step.)
9. i sae apt-get command finished without any errors.
10. i thought i need to reboot my Jetson to apply changes
11. reboot
12. Jetson does’t wake up. (no display output, network lamp is off, failed to establish SSH connection)
13. i rebooted my Jetson again and again
14. i decided to reinstall whole operating system to my Jetson
15. i downloaded the latest Jetpack(5.0.2) and write the image to sd card.
16. try to boot my Jetson with the image but it didn’t wake up.
17. i thought there’s something wrong with the latest version of Jetpack. So, i decided to install the old one which was used in my Jetson.
18. try to boot my Jetson but fail.
19. try to connect my Jetson’s serial console to see what’s happening inside.
20. i was unable to connect the console (maybe my operation was wrong)
21. I’m here to ask for help.

Please give me some help. Best regards.

hello sei23,

if you execute apt-get upgrade, it’ll moving BSP to the latest release version.
there’re some images flash to device, that’s why you re-flash the SD card image not helps.

is it possible to re-flash the target?
you may download JetPack release via SDKManager for installation.

What ‘re-flashing the target’ means?

I need to install SDK manager on normal ubuntu machine and connect Jetson to the Ubuntu, right?

that’s correct, re-flash the target completely through SDKmanger

I got it. I’m now trying to re-flash my Jetson.
I’ll post the result after it finishes.

I tried to flash Jetson Xavier NX, but it failed with following error.

flash: First Error: Jetson board is in a bad state and cannot be recovered. Please manually put board to recovery mode again and retry.

I installed SDKManager on ubuntu on VirtualBox and redirected Jetson USB into the VM. But about 10 seconds after flashing process starts, Jetson suddenly disconnected from both the VM and the VM host machine.

What should i do next?

hello sei23,

that message indicate your target did not enter forced-recovery mode.
please do not use virtual machine, since there’ll be serval USB connection/disconnect during image flashing.

Thanks. I’ll prepare physical ubuntu machine and then try again.

I was finally able to flash my Jetson Xavier NX by SDKManager on Ubuntu 20.04.05 LTS on physical computer.

There’s some errors while flashing and it took long after progress bar reached 99.50%. However, it seems all right after all the flashing process was properly finished.

Thank you very much for support. @JerryChang

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.