Need Help with GeForce 8400GS with Ubuntu 18.04

Hi - I am new here and would appreciate any ideas anyone might have.

I have a Dell Optiplex 790 and have installed a GeForce 8400GS card. I installed the Ubuntu base from the mini.iso file and added the LXDE-core desktop environment. When I boot-up with the VGA cable connected to it, the monitor acts like nothing is connected (screen is black, light is blinking). If I move the cable to the integrated card, I can see the desktop on the monitor.

After I first installed the OS, the card worked with Nouveau, but everything was extremely slow to respond, like I had only 256mb of ram installed (there are 8GB installed. with over 7gb free). I concluded something was amiss with the drivers. Here are the steps I have taken to resolve, but haven’t been able to fix it:

Blacklisted the Nouveau driver (which was what originally showed when I did 
sudo lshw -c display

. Now it shows Nvidia.)
Opened TTY and did:

sudo apt-get purge nvidia*

then

sudo service lightdm stop

, then

sudo add-apt-repository ppa:graphics-drivers

, then

sudo apt-get update

, then

sudo apt-get install nvidia-340
I then rebooted and went to Additional drivers and made sure the 340 card was selected.
I rebooted. It didn't work. I then opened Nvidia Server Settings and installed Prime. It showed Nvidia as the selected card. I then did Prime-Select query and it showed Nvidia.

I think that is all the steps I have done so far. It appears that the system sees the cards, sees the driver, is thinking the Nvidia card is the one I am using (which may explain why things are a bit hinky with the Intel card), but I can’t get the system to actually use the Nvidia card. I am sure I am missing something basic and important…I just can’t figure it out.

Also, I tried connecting the DVI cable. The monitor was recognized, but didn’t wake-up until the start-up process got to the desktop. No splash screen or anything else. Also, when I look at Monitor Settings, it only shows the DVI monitor, even after plugging in the VGA cable as well. In addition, when opening a program (like Firefox), it is unrolling the window, rather than just appearing, if that makes sense.

I have been using Ubuntu for a few years, but am by no means an expert. I am grateful for any ideas.
nvidia-bug-report.log.gz (61.7 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi Generix - thanks for the quick reply. I am inexperienced with shell files, so I did some research on how to run it. I then realized I don’t think I have that file to run and went to https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/ to learn more. Do I need to download something from the NVIDIA site in order to acquire the file you recommended running? If so, can you tell me how to get it?

Thank you!

nvidia-bug-report.sh gets installed alongside the driver, you should be able to run it with
sudo nvidia-bug-report.sh

Thank you for your patience. I have attached the file to my first post.

nvidia-prime sets

Option "IgnoreDisplayDevices" "CRT"

in /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
which disables vga outputs on the nvidia gpu (workaround for buggy notebook bioses)
Either delete that line, or configure your system for nvidia gpu only instead of hybrid intel/nvidia prime.

  • remove nvidia-prime
  • delete /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
  • disable the intel graphics in bios
  • connect all monitors to the nvidia card

Hi Generix -

I edited /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf, saved, and shutdown. I then moved the cable from the VGA to the card and rebooted. The monitor was blinking as if it wasn’t connected to anything, so I moved it back to the VGA, logged in, and looked at the file. It appears it had regenerated and the line I deleted is back in the file. At the top, it says “DO NOT EDIT. AUTOMATICALLY GENERATED BY GPU-MANAGER”

I would prefer to edit the file if I can rather than disabling in BIOS. Do you think that is possible, or do I need to go that route, given the information above?

You can disable the gpu manager with
nogpumanager
kernel parameter.
https://wiki.ubuntu.com/Kernel/KernelBootParameters

Thanks for those instructions. I went to the GRUB menu and edited the line that starts with linux. At the end, it shows $vt_handoff. I entered nogpumanager between the “splash” and “$vt_handoff”. It still booted with the Intel card. Should I maybe type nopgumanager after the $vt_handoff?

nogpumanager just keeps it from overwriting /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf so you can edit it. The intel gpu will always stay the primary gpu unless you disable it in bios.

Okay! I have and update!

I entered nogpumanager into GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub (some research showed that there is a bug in 18.04 that prevents nogpumanager from being effective in the grub menu area). Then I was able to edit the 11-nvidia-prime.conf file and have it stay edited. Then, I rebooted and I am now able to use both the DVI and VGA ports for dual monitors, which is great!

Still having a couple of issues that I was seeing before that I am hoping you might be able to help with.

First, the monitor isn’t waking up until the boot sequence gets to the desktop. Second, windows are acting a bit strange, moving sort of sporadically, seeming to unfold when opening, and just moving windows is taking 20% CPU. Lastly, while the VGA monitor desktop is black, the DVI desktop is pixalated with a cut-off window…similar to what the VGA screen looks like right after log-in before getting to the desktop.

Any thoughts are much appreciated!

Like said, you’ll have to disable the intel gpu, otherwise it will stay primary and the bios and boot messages will only be displayed there.

I apologize…I guess I misunderstood. I was thinking if I did the other steps, I would not need to disable the Intel GPU. I did some research about how to do it and everything I found talked about laptops and notebooks. I have a desktop. Also, I used this card a few years ago in another desktop and didn’t have these issues and didn’t need to disable the Intel gpu. Can you help me understand why I need to do that now and how to do that? And…are you thinking that disabling the Intel gpu will take care of the other issues as well (the pixelation, weird things when moving windows, etc)?

Most boards simply disable the integrated graphics automatically when you plug in an extra graphics card. I guess this was the case with your other board so you didn’t run into problems.
The remaining boards either have a bios switch to disable integrated graphics or it can’t be disabled but there’s a bios switch to set the primary graphics adapter (integrated or pci). Sometimes called “initialize graphics first” or something like that.
The display issues can come from the PRIME mode you’re currently in, please check by creating a /etc/X11/xorg.conf with contents

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  BusID "PCI:4:0:0"
  Option "AllowEmptyInitialConfiguration" "true"
EndSection

Good morning Generix -

thanks for hanging with me through this.

I checked the BIOS and still couldn’t find anything related to the video card. After doing some research, it appears that the BIOS for the Inspiron line doesn’t allow for disabling of the integrated card. My BIOS version is A11,if that helps anything.

I created the file with the contents as stated and don’t see any changes.

Any other thoughts?
nvidia-bug-report.log.gz (59.5 KB)

Please create a new nvidia-bug-report.log with the xorg.conf in place.

Hey Generix -

I just ran the log and attached it to my 10/11 5p post.

I was thinking about what you said about Prime being installed and that contributing to my problems. Would it help if I uninstalled Prime? Or do I need it for something else?
nvidia-bug-report.log.gz (62.2 KB)

nvidia-prime doesn’t matter, it’s overridden by the xorg.conf.
Looking at the xrandr output from the logs, something seems to be wrong with the monitor connected to the dvi port, it uses the integrated analog vga and is not providing an edid. What kind of monitor is this, a vga over dvi-adapter? Which resolution?

Just attached another log to my last post. I didn’t have the DVI monitor connected when I saved the previous log. I apologize…I didn’t realize you needed that. I am using it on my main computer that I use since the one we are talking about isn’t working quite well enough to work on full time.

Hope that makes sense.

Hi Generix -

not sure if my last post came through. I attached a new log with the DVI monitor hooked-up. Does it help show what the problem is?