New admin accounts on TX2 desktop doesn't work?

I’m wondering if anyone knows what I’m doing wrong, or can help me? I’m trying to disable / delete the default ‘nvidia’ and ‘ubuntu’ accounts on my freshly imaged TX2. Briefly, the steps I’m following are:

  1. Image the Tx2 using Jetpack (L4T 28.2, I believe)
  2. Create a new “administrator” account, and enable it, setting a password.
  3. Login using the new account, and disable the “ubuntu” and “nvidia” accounts (by way of passwd -l ).

Unfortunately, logging in with the account created in step 2 shows the desktop with no launcher, and no menu bar. Logging in over SSH however works fine.

Anyone have any ideas what I’m doing wrong? First itme I tried to log in, I got a bunch of “Ubuntu encountered an error” dialog boxes, but these no longer show up.

You may first check that administrator account belongs to video group.
You may clear compiz cache:

sudo rm -r /home/administrator/.cache/compizconfig-1

Perhaps renaming the account would be better than removing it, but even so, I suspect it is asking for trouble.

I tried it using passwd -l for both ubuntu and nvidia accounts, and it seems to be working fine. So far the only problem is when I attempt to log in interactively with the newly created account. The new account works fine over SSH as well.

…At any rate, if I run into any problems, I’ll know where to look first. Thanks!

Thanks for the info. Adding the newuser to the video group fixed the problem.