How to disable automatic login for nvidia account?

Seems like, no matter what I do, the nvidia account is still always automatically logged in to the desktop on boot up of the TX2. I’m running L4T 28.2.

Can someone tell me how to disable this? I’d prefer not to have any accounts automatically log in without typing a password.

I don’t know if this is what I did (I haven’t looked at this in quite some time), but go to “/etc/lightdm/lightdm.conf.d/” and edit file “50-nvidia.conf”:

[SeatDefaults]
allow-guest=false

…this might do the job, but even if not, then this is probably still part of what is needed (basically comment out anything with “autologin” in that file).

I am inclined to believe, that at

Users Accounts-> Automatic Login

you may manipulate with the autologin feature
reference: https://help.ubuntu.com/stable/ubuntu-help/user-autologin.html.en

Yes, I thought so too, but that doesn’t actually do anything, apparently.

I think the initial state (autologin on) is displayed wrong (off).
I just enabled autologin in Ubuntu settings, saved, then disabled, and it was enough.
Note that you have to unlock (with lock icon and then giving password from an sudoer account) for changing this.

yep, I am inclined to believe it worked in my case as well, after some clicks of mouse.
It may require to unlock the toggle, though.