Nano 2G, disable login window after boot up

Hi,

I flashed my nano 2G with jetpack4.6 through SDK manager.
When the 2G boot up it has this window, how can I disable it? Thx
BTW, there is only one account

That’s the “display manager” (a.k.a., the login manager). When X starts it can only run one program. When you are logged in, that is the desktop manager, and this is what is capable of multitasking and doing multiple things. The display manager is similar, but its only job is to overwrite itself upon login and transfer to a display manager owned by the person who logged in.

What you are asking is to disable the display manager. Are you asking to disable login? Or remove the GUI? Or auto login? Any of those can have consequences. Maybe describe what it is you wish to achieve as some sort of use-case.

Hi,

I have an autorun application. If there is any power outrage and the board restarts, I want the application runs automatically.
But now, I have to click login button before it can go to the desktop screen and run my application.
Thx

I have not personally set it up, but probably the simplest thing to do is to enable auto-login (fairly easy), with login running your app. This is not as straightforward, but if your app runs by itself and no other interaction is expected, e.g., the user won’t be opening other applications or multitasking (but will perhaps interact with just that application), then you could set up the X server start to run (as its single application) your application instead of a login manager (and thus also not run a desktop manager, e.g., no shells available, but fewer resources required).

May I know where I can set it? I have searched through the User option…

Alternatively, I found this forum, I will try it tomorrow, but some said it does not work…
NVIDIA Jetson Nano 2GB Auto Login doesn’t work - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums

Jetson Nano auto log in account when poweron without need to press enter - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums

Thanks,

Someone else may need to help with auto login since I don’t use this. I did see the GUI app for changing this listed here:
https://linuxconfig.org/how-to-enable-automatic-login-on-ubuntu-18-04-bionic-beaver-linux
(but as the other thread states, this might not work)

The above also mentions how to change this with the command line. I noticed the command line also mentions a commented-out parameter:
#WaylandEnable=false

If auto login does work, then you might need to also use “WaylandEnable=true”.

EDIT: This also makes me wonder if regular login has Wayland disabled. Not sure how to test if it is “installed but not enabled” (won’t matter if you don’t use Wayland).

Hi,

This one works. :>

$ sudo vim /etc/lightdm/lightdm.conf.d/50-nvidia.conf
Add below two lines:
autologin-user=nvidia
autologin-user-timeout=0