New Jetson Nano - HDMI cable not working on Dell Monitor P2217

I am trying to setup a new Jetson Nano Development Kit.

  1. Created the latest image on a new microSD card.
  2. Connected to USB power. Jetson powers up.
  3. Connected a new HDMI cable.
    (The cable is good, it works ok on a Dell Laptop connected to a Dell Docking station.)
  4. When I connect this to the Jetson, the monitor does not detect the HDMI cable. Tried several times, No luck.

Any suggestions what I should try next? I even tried flashing an older version of the image but still no output on the monitor.

Thank you

If you have serial console, then you should attach a full serial console boot log. Regardless, if you monitor “dmesg --follow”, and only then plug in the HDMI cable, what is appended to the log? Be sure you don’t see the word “quiet” anywhere in “/boot/extlinux/extlinux.conf” (remove that word then reboot if it is there).

One more test, with the HDMI cable connected: What do you see for output from this:

sudo -s
cat `find /sys -name 'edid'`

Btw, is this a true HDMI monitor without need for any adapter?

Link for how to use serial console.

Dump the log as linuxdev’s suggestion here.

1 Like

Thank you for your reply.

How do I monitor “dmesg --follow” or type anything else. The monitor shows no output. It is a Dell P2217 monitor which does not require an HDMI adapter. I used a HDMI to HDMI cable.

It is a brand new Jetson Nano that I am trying to setup for someone. Unfortunately I don’t have any other power source beside USB. It powers up with the USB ok. I have a keyboard and mouse connected but see no output from the HDMI cable.

Thank you

Thanks for the info.

I have a Jetson Nano 2GB

It does not have a barrel jack port. In the ones with the barrel jack it is possible to power from the barrel jack and get a serial connection from the USB-C. If I power with a USB-C can I get a serial from the micro USB or USB port?

Thank you

I am not asking you to dump log from usb port. Please do read posts first.

That console is not from usb.

Apologies for the confusion. I dont have a TTL conversion cable and was asking another question,

For a Nano with a barrel jack you can power from the barrel jack and connect to the micro-USB.

Can I do something similar to get a serial connection or is using a TTL/USB the only way?
Appreciate your suggestions. Thank you

Using usb ttl is the only way.

1 Like

Thank you

You would use serial console. Serial console is very hard to break since it requires almost no drivers. If there is already a login account, then you could also use ssh ethernet login. Sometimes you can ignore the GUI and switch to a text-only console when the GUI fails, e.g., via the CTRL-ALT-F2 key binding (just hold down CTRL key, ALT key, and then tap the F2 key…see if a text-only login shows up).

In just about every scenario the serial console is the king of debugging access. It tends to “just work” even when much of the system is dead. In the case of the serial console the program for the console runs on a different host PC computer, so none of that software needs to function on the Jetson if the serial port is working with console.

Thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.