No header and timestamp with camera helper ROS1

I am trying to get rgb images and corresponding bounding boxes from Isaac Sim and I am using Action graphs to accomplish this. I have attached an image of my action graph and bounding box output for reference. The problem is that the rosmsg is almost entirely empty. I am just getting the ID and the bounding box coordinates but nothing else. Right now, getting time stamps and header is more important. How can modify my action graph to get that?

I still have not found the solution. I am not sure what the mistake is, I have replicated the same ROScameras setup from an example provided but still not getting an header and timestamps. I noticed this error in the terminal.
I have updated my IsaacSim as well. It is on the latest version now. The graph looks like as shown in the screenshot below.

Hi @a.imrantw - Can you please confirm that you are following this section?

Also, can you pls confirm your configuration of Isaac Sim?

The complete simulation was created in Isaac Sim 2022.X. i recently updated to 2023.X and just changed the camera setup with ROS suggested in the link you have shared. Still having the same issue.

Starting from 2023 release, below are the version and flavors supported for ROS/ROS2. Can you confirm what platform you are using?

I am using Ubuntu 20 with ROS Noetic.

Hi @a.imrantw
Are you seeing this issue with Isaac Sim 2023.1.1? Could you verify that other ROS1 nodes publish properly?

Removing and reinstalling Isaac Sim solved it. Yes, I was/am using Isaac Sim 2023.1.1 and the node is publishing correctly.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.