No module names boto3

am getting this error when training to run the open images downloader script in the container.


Please try to install it with pip3:

$ sudo pip3 install boto3


Hmm this package should already be installed in the jetson-inference container. Which version of JetPack-L4T are you running?

If you run python3 inside the container, are you able to import boto3? Are you able to import pandas?

hi thanks
i did try that both in the mean system and after i run the container but still getting the same result. i also removed and redownloaded the jetson-interface, didnt work either.

the latest version JetPack 4.5.1
forgive me cz am new to this but how can i check that

OK, that should be fine. If you run the following, does it make error?

$ cd /path/to/your/jetson-inference
$ docker/
$ python3 -c 'import boto3'   # run this inside the container

yes it gives "no module names boto3

Are you sure you are running the python3 -c 'import boto3' command inside the container? I doubled checked the same container version you are using, and was able to import boto3 without issue.

yeah did that couple of times and didnt work so eventually i just reburned the image and started over

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.