No screen on Tegra B HDMI

Drive PX2 installed via the DriveInstall_4.1.8.0L_SDK_b43.run, both Tegra’s flashed, finished with the aurix flash. Display connected on tegra A HDMI works fine. Display connected on tegra B HDMI gives black screen.

Try to connect a keyboard & a mouse through USB Port Hub to TegraB-USB, then restart the system(not to reboot, but to power off and then power on).

Have a try.

Hi,

Same problem here for the P2379. Any updates or solutions to this issue?

Furthermore, I cannot use mouse or keyboard on the USB2.0 hub host. They are not recognized or powered by the system. At the moment, keyboard and mouse are attached to a USB3.0 port using a USB hub. However, I would need that USB3.0 ports free for dedicated storage or network connections to TegraA/B.
Do I need to change any settings for the USB2.0 connector to accept just a keyboard and mouse?

Thank you

For me the proposed answer by wenwu.deng worked, thanks!

I tried but didn’t worked. Keyboard and mouse are ready but screen is black. I checked I am connected to TegraB ports and power cycled 3 times without success.
However, I am able to connect to TegraB by ssh from TegraA session. HDMI for TegraA works fine.

Same problem at my system, but with latest DriveInstall 5.0.5.0a
Any news related to this? SSH to Tegra B is still available.

Dear felix.elrod,

Does the same problem continue after the DriveInstall 5.0.5.0a update? Thanks

Hello SteveNV,
thank you for your quick reply.
Yes, the same problem continues after the DriveInstall 5.0.5.0a update.

install 5.0.5.0a and firmware aurix firmware update.

Tegra B, we able to see HDMI screen for drivepx2 setup.

But we couldn’t get keyboard and mouse to recognize thru any usb port.

We try to power on and off many cycles for different port. No luck.

Hello,
the problem with the black screen is fixed for me, now. Don’t know, what I changed :-/.
Keyboard and mouse is also working at my system. Don’t know, what your Problem might be, sorry

Hello,
I’ve the same problem.
USB works fine on TegraA but do not work on tegra B.
News on possible solutions?

Dear andrea.marchese,

Have you updated your DPX2 PDK to the latest version?
If not, could you please update DPX2 PDK?

And could you check if you can access TegraB via minicom on host PC?
sudo minicom -D /dev/ttyUSB6
(ttyUSB2 for Tegra A, or ttyUSB6 for Tegra B)

Hi @SteveNV,
thanks for your reply.

Unfortunatly, using proxy I’m not able to complete the login on DEVZONE using the new SDKManager.
Can you check if there is a fix for this problem?

In the meantime I’ll try if I can access using minicom

Thanks

Dear andrea.marchese,

Could you refer to “Proxy Settings” part in NVIDIA SDK Manager User Guide to learn how to use SDK Manager for your topic?
https://developer.nvidia.com/nvidia-drive-downloads

Hi SteveNV,
I have already tried to configure it but the login screen once pressed on DEVZONE remains empty and does not allow me to enter the username and password fields.

Dear andrea.marchese,

So do you mean the login screen like below does not appear?

Exactly!
Adding export of http_proxy and https_proxy before launch of sdkmanager the login screen appear but after click of login button it remains stalled with no response.

It is the same on my system: After pressing the login-button just three bubles are ‘blinking’ for more than 10 minutes now. Nothing else happens.

Dear andrea.marchese and felix.elrod

Can I know if you can use the SDK manager without proxy setting?

Hi SteveNV,

sorry, this is currently impossible to test due to our company network settings.